Bug 182244 - yum shell AttributeError traceback on wrong command
yum shell AttributeError traceback on wrong command
Status: CLOSED DUPLICATE of bug 181454
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 07:45 EST by Sander Hoentjen
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 08:37:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sander Hoentjen 2006-02-21 07:45:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
Yum shell doesn't handle bad commands gracefully anymore

Version-Release number of selected component (if applicable):
yum-2.5.1-5

How reproducible:
Always

Steps to Reproduce:
1. # yum shell
2. > foo

  

Actual Results:  # yum shell
Loading "installonlyn" plugin
Setting up Yum Shell
> foo
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 438, in doShell
    yumshell.cmdloop()
  File "/usr/lib/python2.4/cmd.py", line 142, in cmdloop
    stop = self.onecmd(line)
  File "/usr/lib/python2.4/cmd.py", line 218, in onecmd
    return self.default(line)
  File "/usr/share/yum-cli/shell.py", line 75, in default
    self.do_help('')
  File "/usr/share/yum-cli/shell.py", line 92, in do_help
    msg = self.base.optparser.print_short_help()
AttributeError: YumOptionParser instance has no attribute 'print_short_help'


Expected Results:  print_short_help :)

Additional info:
Comment 1 Seth Vidal 2006-02-21 08:37:38 EST

*** This bug has been marked as a duplicate of 181454 ***

Note You need to log in before you can comment on or make changes to this bug.