Bug 182298 - hp xw9300 integrated scsi controller not recognized on install
hp xw9300 integrated scsi controller not recognized on install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened, Triaged
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2006-02-21 12:53 EST by Eli Collins
Modified: 2009-12-18 00:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 00:51:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci once booted fc5 test3 x86_64 with pci=noacpi (1.60 KB, text/plain)
2006-03-06 18:47 EST, Eli Collins
no flags Details
dmesg once booted fc5 test3 x86_64 with pci=noacpi (23.77 KB, text/plain)
2006-03-06 18:48 EST, Eli Collins
no flags Details

  None (edit)
Description Eli Collins 2006-02-21 12:53:38 EST
The installer does not list my scsi disks as installation targets, just my ide
disk. Filing as a kernel bug as I assume the issue is due to linux not
recognizing the scsi controller. I tried starting the installer with 'linux
noacpi', no dice. This is an issue with FC4 x86_64 as well.

The machine is an HP xw9300, the motherboard has an integrated ultra 320 scsi
controller. bios is updated to latest rev 2.05.  

SuSE 9.3 (i386) and SuSE 10 beta 4 (x86_64) can both see the scsi disks when I
start their installers with noacpi.
Comment 1 Dave Jones 2006-03-06 12:45:17 EST
can you grab lspci output for that ? (and maybe dmesg too?)
Comment 2 Dave Jones 2006-03-06 12:50:49 EST
Peter, Jeremy tells me you've got one of these beasts.
Any ideas whats up ?
Comment 3 Eli Collins 2006-03-06 13:52:26 EST
Booting with pci=noacpi fixes it. The machine's MP and ACPI tables don't tell
the same interrupt routing story.
Comment 4 Eli Collins 2006-03-06 18:47:17 EST
Created attachment 125736 [details]
output of lspci once booted fc5 test3 x86_64 with pci=noacpi
Comment 5 Eli Collins 2006-03-06 18:48:41 EST
Created attachment 125737 [details]
dmesg once booted fc5 test3 x86_64 with pci=noacpi
Comment 6 Dave Jones 2006-10-16 17:42:52 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 Dave Jones 2006-11-24 17:14:01 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.
Comment 8 Gilboa Davara 2006-11-24 23:41:27 EST
Still no go both latest FC5 kernels and FC6 kernels require acpi=off in-order to
detect all the devices on the PCI-X bridge.

- Gilboa
Comment 9 Gilboa Davara 2006-11-24 23:42:20 EST
Marking as info provided.
Comment 10 Jon Stanley 2008-02-05 08:35:20 EST
Closing since there was an error in previous mass-close and they remained in
NEEDINFO.
Comment 11 Gilboa Davara 2009-02-15 10:55:34 EST
Somehow I missed this bug.
Still seeing the same in F10, x86_64.

Nothing is seen on the PCI-X/PCI-E buses unless I add acpi=off

- Gilboa
Comment 12 Bug Zapper 2009-11-18 03:05:49 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-12-18 00:51:35 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.