Bug 182321 - "xm list" crashes after a domain has been shutdown with reboot -f
"xm list" crashes after a domain has been shutdown with reboot -f
Status: CLOSED DUPLICATE of bug 179677
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 15:35 EST by Stephen Tweedie
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 15:30:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-02-21 15:35:59 EST
Description of problem:
After a guest domain has been created and then shut down from inside with
  /sbin/reboot -f
the domain does not shutdown cleanly; and furthermore, xend seems to corrupt its
internal state, as subsequent "xm list" commands fail with Xen protocol errors.

Version-Release number of selected component (if applicable):
xen-3.0.1-0.20060208.fc5.2
kernel-xen-hypervisor-2.6.15-1.1969_FC5

How reproducible:
100% (on x86_64, have not tried i386 yet.)

Steps to Reproduce:
1. xm create -c $guest 
2. Inside guest, run (as root) /sbin/reboot -f
3. Inside dom0, "xm list"
  
Actual results:
xm list crashes

Expected results:
xm list should not crash.

Additional info: 
Doing a "service xend restart" restores normal service.

The "xm list" traceback is:

[root@dhcp83-39 ~]# xm list
Unexpected error: xen.xend.XendProtocol.XendError

Please report to xen-devel@lists.xensource.com
Traceback (most recent call last):
  File "/usr/sbin/xm", line 10, in ?
    main.main(sys.argv)
  File "/usr/lib64/python2.4/site-packages/xen/xm/main.py", line 906, in main
    rc = cmd(args)
  File "/usr/lib64/python2.4/site-packages/xen/xm/main.py", line 356, in xm_list
   doms = getDomains(params)
  File "/usr/lib64/python2.4/site-packages/xen/xm/main.py", line 332, in getDomains
    return server.xend_list_domains()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendClient.py", line 200, in
xend_list_domains
    return self.xendGet(self.domainurl(), {'detail': '1'})
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendClient.py", line 150, in
xendGet
    return self.client.xendGet(url, args)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendProtocol.py", line 92,
in xendGet
    return self.xendRequest(url, "GET", args)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendProtocol.py", line 182,
in xendRequest
    resp.reason)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendProtocol.py", line 112,
in handleStatus
    return self.handleException(XendError(message))
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendProtocol.py", line 138,
in handleException
    raise err
xen.xend.XendProtocol.XendError: Internal server error
Comment 1 Stephen Tweedie 2006-02-21 15:39:05 EST
Running "/sbin/poweroff -f" within the guest domain quits it without any
problems, btw.
Comment 2 Jeremy Katz 2006-02-22 15:30:54 EST

*** This bug has been marked as a duplicate of 179677 ***

Note You need to log in before you can comment on or make changes to this bug.