Bug 1823451 - HTTP errors returned in the response json are being swallowed
Summary: HTTP errors returned in the response json are being swallowed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1823452
TreeView+ depends on / blocked
 
Reported: 2020-04-13 18:09 UTC by Rohit Rai
Modified: 2020-07-13 17:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1823452 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
The bug has validated successfully and this is the screenshot of it. (155.06 KB, image/png)
2020-04-15 09:31 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5024 0 None closed Bug 1823451: Fix error handling in coFetch to return json.error 2020-06-23 10:00:47 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:45 UTC

Description Rohit Rai 2020-04-13 18:09:27 UTC
Description of problem: HTTP errors returned in the response body are being swallowed by the coFetch erro handling mechanism and only the response status is being returned as error.


Version-Release number of selected component (if applicable):


How reproducible: Always.


Steps to Reproduce:
1. Install the nodejs-ex-k Helm Chart from the developer catalog.
2. Try to install that same chart again.


Actual results:
The error message says `Bad Gateway`

Expected results:
The error should say - 'Failed to install helm chart: cannot re-use a name that is still in use'

Additional info:

Comment 3 Gajanan More 2020-04-15 09:31:24 UTC
Created attachment 1678981 [details]
The bug has validated successfully and this is the screenshot of it.

Comment 4 Gajanan More 2020-04-15 09:33:35 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-04-14-231423
Browser: Google Chrome Version 78.0.3904.108
Marking this as done. 
Please have a look at the screenshot taken while validating the bug.

Comment 5 errata-xmlrpc 2020-07-13 17:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.