Bug 1823452 - HTTP errors returned in the response json are being swallowed
Summary: HTTP errors returned in the response json are being swallowed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1823451
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-13 18:10 UTC by Rohit Rai
Modified: 2020-05-04 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1823451
Environment:
Last Closed: 2020-05-04 11:49:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error when we try to install the helm chart with same name (135.20 KB, image/png)
2020-04-22 09:23 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5039 None closed [release-4.4] Bug 1823452: Fix error handling in coFetch to return json.error 2020-05-01 22:13:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:49:51 UTC

Description Rohit Rai 2020-04-13 18:10:34 UTC
+++ This bug was initially created as a clone of Bug #1823451 +++

Description of problem: HTTP errors returned in the response body are being swallowed by the coFetch erro handling mechanism and only the response status is being returned as error.


Version-Release number of selected component (if applicable):


How reproducible: Always.


Steps to Reproduce:
1. Install the nodejs-ex-k Helm Chart from the developer catalog.
2. Try to install that same chart again.


Actual results:
The error message says `Bad Gateway`

Expected results:
The error should say - 'Failed to install helm chart: cannot re-use a name that is still in use'

Additional info:

Comment 3 Gajanan More 2020-04-22 09:23:14 UTC
Created attachment 1680754 [details]
Error when we try to install the helm chart with same name

Comment 4 Gajanan More 2020-04-22 09:27:29 UTC
I have validated the bugzilla on
Build:4.4.0-0.ci-2020-04-17-081422
Browser: Google Chrome Version 78.0.3904.108
Please have a look at the attachment
Marking this as verified.

Comment 6 errata-xmlrpc 2020-05-04 11:49:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.