Bug 182351 - Does not compile because libpam not found
Does not compile because libpam not found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-21 18:02 EST by Michael H. Schimek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.86
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 16:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael H. Schimek 2006-02-21 18:02:15 EST
The usermode-1.85 source does not compile on my box because configure cannot
find libpam and libpam_misc:

checking for pam_start... no
checking for pam_start in -lpam... no
/usr/src/usermode-1.85/configure: line 7597: dl: command not found
checking for misc_conv... no
checking for misc_conv in -lpam_misc... no

config.log:

configure:7530: checking for pam_start in -lpam
configure:7560: gcc -o conftest -g -O2   conftest.c -lpam   >&5
/usr/lib/gcc/i686-pc-linux-gnu/4.0.2/../../../libpam.so: undefined reference to
`dlerror'
/usr/lib/gcc/i686-pc-linux-gnu/4.0.2/../../../libpam.so: undefined reference to
`dlclose'
/usr/lib/gcc/i686-pc-linux-gnu/4.0.2/../../../libpam.so: undefined reference to
`dlopen'
/usr/lib/gcc/i686-pc-linux-gnu/4.0.2/../../../libpam.so: undefined reference to
`dlsym'
collect2: ld returned 1 exit status

Apparently in configure.in AC_CHECK_LIB the action-if-not-found is missing:

AC_CHECK_FUNC(pam_start,,[AC_CHECK_LIB(pam,pam_start,PAM_LIBS="-lpam -ldl",dl)])
AC_CHECK_FUNC(misc_conv,,[AC_CHECK_LIB(pam_misc,misc_conv,PAM_LIBS="-lpam_misc
$PAM_LIBS",$PAM_LIBS)])
Comment 1 Jindrich Novy 2006-02-22 03:43:55 EST
It seems you haven't installed glibc-devel on your system. Usermode has an
explicit dependency to pam-devel. So that rpmbuild won't let you go on building
the package when libpam.so is missing.
Comment 2 Michael H. Schimek 2006-02-22 22:09:05 EST
I don't have a RedHat system. I tried to build usermode-1.85.tar.bz2 from the
usermode-1.85-2.2.src.rpm by hand. The AC_CHECK_FUNC tests for pam_start and
misc_conv succeed only if I configure with LIBS="-lpam -ldl -lpam_misc". The
AC_CHECK_LIB tests which try -lpam and -lpam_misc explicitely are broken,
passing dl and $PAM_LIBS as action-if-not-found instead of other-libraries, and
dl should be -ldl.
Comment 3 Jindrich Novy 2006-02-23 04:45:24 EST
Confirmed. I fixed it upstream, thanks. The fixed configure.in will be present
since usermode-1.86-1 release. I'll close this bug after it's released. Thanks.
Comment 4 John Thacker 2006-10-28 16:53:40 EDT
Closing bug per previous comment.

Note You need to log in before you can comment on or make changes to this bug.