Bug 1823616 - Create button is disabled on Dev console when deploy image by searching digest image for container
Summary: Create button is disabled on Dev console when deploy image by searching diges...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1824429 1829944
TreeView+ depends on / blocked
 
Reported: 2020-04-14 03:32 UTC by XiaochuanWang
Modified: 2020-07-13 17:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:27:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
screen recording for bug (6.69 MB, video/quicktime)
2020-04-14 03:32 UTC, XiaochuanWang
no flags Details
Create button enabled (305.46 KB, image/png)
2020-06-01 01:30 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5069 0 None closed Bug 1823616: Make Tag field optional for the ImageStreamImport validation schema 2020-08-11 03:48:20 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:27:45 UTC

Description XiaochuanWang 2020-04-14 03:32:12 UTC
Created attachment 1678613 [details]
screen recording for bug

Description of problem:
On Dev console, try to deploy image by searching a digest container image, Create button is disabled.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-04-09-220855

How reproducible:
Always

Steps to Reproduce:
1.Login and browse to Dev console
2.Try to deploy an image by searching a digest container image: Click Add -> Container Image, input:
 docker.io/aosqe/hello-openshift@sha256:a2d509d3d5164f54a2406287405b2d114f952dca877cc465129f78afa858b31a
3. After image validation succeed, fill in other required fields, check the Create button

Actual results:
3. Create button is disabled.

Expected results:
3. Create button is enabled.

Additional info:

Comment 3 Yadan Pei 2020-06-01 01:30:58 UTC
Created attachment 1693968 [details]
Create button enabled

Search with image digest, Create button is enabled and user can create resources successfully

Verified on 4.5.0-0.nightly-2020-05-30-025738

Comment 4 errata-xmlrpc 2020-07-13 17:27:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.