Bug 1824429 - Create button is disabled on Dev console when deploy image by searching digest image for container
Summary: Create button is disabled on Dev console when deploy image by searching diges...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1829944 (view as bug list)
Depends On: 1823616
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-16 08:37 UTC by Jakub Hadvig
Modified: 2020-08-18 11:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-18 11:45:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5141 0 None closed [release-4.4] Bug 1824429: Make Tag field optional for the ImageStreamImport validation schema 2020-08-10 14:50:47 UTC
Red Hat Product Errata RHBA-2020:3334 0 None None None 2020-08-18 11:46:11 UTC

Description Jakub Hadvig 2020-04-16 08:37:36 UTC
This bug was initially created as a copy of Bug #1823616

I am copying this bug because: 



Description of problem:
On Dev console, try to deploy image by searching a digest container image, Create button is disabled.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-04-09-220855

How reproducible:
Always

Steps to Reproduce:
1.Login and browse to Dev console
2.Try to deploy an image by searching a digest container image: Click Add -> Container Image, input:
 docker.io/aosqe/hello-openshift@sha256:a2d509d3d5164f54a2406287405b2d114f952dca877cc465129f78afa858b31a
3. After image validation succeed, fill in other required fields, check the Create button

Actual results:
3. Create button is disabled.

Expected results:
3. Create button is enabled.

Additional info:

Comment 1 Jakub Hadvig 2020-05-07 08:12:44 UTC
*** Bug 1829944 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Hadvig 2020-05-08 13:54:10 UTC
waiting for dependent bug to be verified.. backport PR is up https://github.com/openshift/console/pull/5141

Comment 3 Jakub Hadvig 2020-05-29 13:42:40 UTC
still waiting for dependent bug to be verified.. backport PR is up https://github.com/openshift/console/pull/5141

Comment 4 Yadan Pei 2020-06-01 01:33:20 UTC
dependent bug is verified on 4.5.0-0.nightly-2020-05-30-025738

Comment 5 Jakub Hadvig 2020-06-19 07:44:32 UTC
Waiting bug bug to be verified. Adding UpcomingSprint to have it reevaluated in the next cycle.

Comment 11 Yanping Zhang 2020-08-11 03:54:38 UTC
Checked on OCP 4.4 cluster with payload 4.4.0-0.nightly-2020-08-10-202559.
Deploy an image by searching a digest container image: Click Add -> Container Image, input:
 docker.io/aosqe/hello-openshift@sha256:a2d509d3d5164f54a2406287405b2d114f952dca877cc465129f78afa858b31a
Input other required field, the "Create" button is enabled, and could create successfully.
The bug is fixed.

Comment 13 errata-xmlrpc 2020-08-18 11:45:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3334


Note You need to log in before you can comment on or make changes to this bug.