Bug 1824049 - click "Machine Config Pools" after mcp creation making page crash
Summary: click "Machine Config Pools" after mcp creation making page crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1824029
Blocks: 1825722
TreeView+ depends on / blocked
 
Reported: 2020-04-15 07:40 UTC by shahan
Modified: 2020-06-29 15:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1824029
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5102 None closed [release-4.4] Bug 1824049: Handle undefined MachineConfigPools status 2020-07-15 13:08:26 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:17 UTC

Description shahan 2020-04-15 07:40:56 UTC
+++ This bug was initially created as a clone of Bug #1824029 +++

Description of problem:
click "Machine Config Pools" after mcp creation making page crash 

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-14-194131

How reproducible:
Always

Steps to Reproduce:
1. goto k8s/cluster/machineconfiguration.openshift.io~v1~MachineConfigPool/~new, create MachineConfigPool by console default yaml 
2. After clicking ‘Create’ button then click 'Compute->Machine Config Pool' at the left navigate item
3.

Actual results:
2. Then got the error: Oh no! Something went wrong.

TypeError
Description:
Cannot destructure property 'conditions' of 'e.status' as it is undefined.

Component Trace:
in x
    in d
    in B
    in div
    in div
    in t
    in t
    in o
    in div
    in V
    in div
    in Data
    in StatusBox
    in div
    in a
    in w
    in w
    in div
    in div
    in div
    in ListPageWrapper_
    in Unknown
    in Unknown
    in w
    in x
    in w
    in div
    in w
    in w
    in w
    in MultiListPage
    in Unknown
    in o
    in ListPage
    in P
    in c
    in div
    in Unknown
    in Unknown
    in w
    in w
    in t
    in t
    in div
    in div
    in section
    in d
    in Unknown
    in w
    in w
    in div
    in f
    in div
    in f
    in NotificationDrawer
    in Unknown
    in w
    in Unknown
    in Unknown
    in w
    in x
    in w
    in main
    in div
    in y
    in component
    in t
    in t
    in t
Stack Trace:
TypeError: Cannot destructure property 'conditions' of 'e.status' as it is undefined.
    at N (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/machine-config-pool-chunk-66f84e004848a67a6e2f.min.js:1:3863)
    at x (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/machine-config-pool-chunk-66f84e004848a67a6e2f.min.js:1:8912)
    at rowRenderer (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/main-chunk-4fae3b97a9097206fa9d.min.js:1:835723)
    at https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:184:41032
    at r (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:132:74139)
    at x._calculateChildrenToRender (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:132:64231)
    at x.render (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:132:61524)
    at va (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:155:65523)
    at ma (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:155:65318)
    at Ks (https://console-openshift-console.apps.qe-groupd-0415.qe.devcluster.openshift.com/static/vendors~main-chunk-2ed1b3961c78f3f83aa0.min.js:155:99601)
Expected results:


Additional info:

Comment 4 Jakub Hadvig 2020-06-19 07:16:22 UTC
Waiting to get Verified. Adding UpcomingSprint to have it reevaluated in the next cycle.

Comment 7 shahan 2020-06-22 03:09:56 UTC
No runtime error when creating the machineconfigpool
4.4.0-0.nightly-2020-06-21-210301

Comment 9 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.