Bug 1824180 - Add support for libvirt IPI installs in openshift/installer master --> 4.4 on s390x and ppc64le
Summary: Add support for libvirt IPI installs in openshift/installer master --> 4.4 on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Multi-Arch
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Prashanth Sundararaman
QA Contact: Barry Donahue
URL:
Whiteboard:
Depends On: 1824172
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-15 13:49 UTC by Andy McCrae
Modified: 2020-06-02 11:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-02 11:17:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 3457 None closed Bug 1824180: Backport adding groundwork for multi-arch images 2020-06-18 14:20:21 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:14 UTC

Description Andy McCrae 2020-04-15 13:49:15 UTC
This bug was initially created as a copy of Bug #1824172

I am copying this bug because: 



Description of problem:

For ppc64le and s390x, changes went in to 4.3 to make libvirt IPI work:
https://github.com/openshift/installer/pull/3233

We need to make those changes across master --> 4.4

How reproducible: All the time

Steps to Reproduce:
1. Attempt to install 4.4/4.5 on ppc64le or s390x using Libvirt IPI


Actual results:
Doesn't work at all.

Expected results:
Works

Comment 1 Andy McCrae 2020-04-30 14:43:31 UTC
We've run through an install using the PR listed and successfully brought up a 4.4 cluster on P & Z

Comment 10 Barry Donahue 2020-05-25 11:01:19 UTC
David could you verify?

Comment 12 David Benoit 2020-05-26 17:26:27 UTC
Looks like it was successful in CI.

Comment 14 errata-xmlrpc 2020-06-02 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.