Bug 1824254 - OperatorHub: Installed Operators provided APIs view more link should go to operator details tab
Summary: OperatorHub: Installed Operators provided APIs view more link should go to op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1824255
TreeView+ depends on / blocked
 
Reported: 2020-04-15 16:14 UTC by bpeterse
Modified: 2020-07-13 17:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The cause was a link to the wrong page. I updated the link, which fixed the problem.
Clone Of:
: 1824255 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:27:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5159 None closed Bug 1824254: Update "view more" apis link 2020-07-16 15:44:51 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:28:28 UTC

Description bpeterse 2020-04-15 16:14:30 UTC
Description of problem:

Clicking on the "View x more.." link under provided APIs will redirect a user to the Instances tab rather than the Details tab on an operator page.


How reproducible:
Always

Steps to Reproduce:
1. Navigate to OperatorHub
2. Install an operator such as Crunchy PostgresSQL operator or Cluster Application Migration operator
3. Navigate to the Installed Operators page
4. Click the "View x more..." link under provided APIs

Actual results:

User will be redirected to the Instances tab for the operator.


Expected results:

User should be redirected to the Details tab, which lists the rest of the provided APIs.

Comment 3 Yanping Zhang 2020-04-26 04:05:10 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.nightly-2020-04-25-170442. Install operator eg "3Scale API Management" in project, then click "View 4 more" link on "Installed Operators" page, it will go to the installed operator's Details tab.

Comment 4 errata-xmlrpc 2020-07-13 17:27:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.