Bug 1824255 - OperatorHub: Installed Operators provided APIs view more link should go to operator details tab
Summary: OperatorHub: Installed Operators provided APIs view more link should go to op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1824254
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-15 16:15 UTC by bpeterse
Modified: 2020-06-23 00:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The url for the "view more" link was incorrect. I updated it, which fixed the bug.
Clone Of: 1824254
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5320 None closed [release-4.4] Bug 1824255: Update "view more" apis link 2020-06-19 18:13:56 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:42 UTC

Description bpeterse 2020-04-15 16:15:55 UTC
+++ This bug was initially created as a clone of Bug #1824254 +++

Description of problem:

Clicking on the "View x more.." link under provided APIs will redirect a user to the Instances tab rather than the Details tab on an operator page.


How reproducible:
Always

Steps to Reproduce:
1. Navigate to OperatorHub
2. Install an operator such as Crunchy PostgresSQL operator or Cluster Application Migration operator
3. Navigate to the Installed Operators page
4. Click the "View x more..." link under provided APIs

Actual results:

User will be redirected to the Instances tab for the operator.


Expected results:

User should be redirected to the Details tab, which lists the rest of the provided APIs.

Comment 1 ralpert 2020-05-08 17:19:28 UTC
Have a PR up for this waiting for review: https://github.com/openshift/console/pull/5320

Comment 2 ralpert 2020-05-28 14:15:40 UTC
Have a PR up for this waiting for merge (approved).

Comment 6 Yanping Zhang 2020-06-11 08:06:07 UTC
Checked on ocp 4.4 cluster with payload 4.4.0-0.nightly-2020-06-11-012529
1. Install Crunchy PostgresSQL operator.
2. Navigate to the Installed Operators page
3. Click the "View x more..." link under provided APIs, will go to the detail tab of the subscription, and all apis are listed on the page.
The bug is fixed.

Comment 8 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.