Bug 182453 - beagle's %post should use %libdir, not /usr/lib
beagle's %post should use %libdir, not /usr/lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 182467 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 12:28 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 05:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-02-22 12:28:23 EST
Description of problem:
Installing today's beagle on x86_64 produces the following output:

firefox-1.5.0.1-3
/var/tmp/rpm-tmp.65566: line 5: cd: /usr/lib/firefox-1.5.0.1/extensions: No such
file or directory
unzip:  cannot find or open /usr/lib/beagle/beagle.xpi,
/usr/lib/beagle/beagle.xpi.zip or /usr/lib/beagle/beagle.xpi.ZIP.
grep: beagle-extension/install.rdf: No such file or directory
mv: target `' is not a directory: No such file or directory
error: %post(beagle-0.2.1-8.x86_64) scriptlet failed, exit status 1

Both beagle/beagle.xpi and firefox-1.5.0.1/extensions are in /usr/lib64, not
/usr/lib.  The firefox version output should probably be omitted.

Version-Release number of selected component (if applicable):
beagle-0.2.1-8.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.yum update beagle
Comment 1 Ignacio Vazquez-Abrams 2006-02-22 12:30:12 EST
The plugin could probably go in %{_libdir}/mozilla/plugins instead.
Comment 2 Alexander Larsson 2006-02-23 05:12:00 EST
*** Bug 182467 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Larsson 2006-02-23 05:18:16 EST
should be fixed in 0.2.1-10
Comment 4 Alexandre Oliva 2006-02-23 13:10:33 EST
Confirmed, thanks!

Note You need to log in before you can comment on or make changes to this bug.