Bug 182472 - Video corruption, ATI Radeon 7000 and ES1000 - Display Engine stops issuing MC requests.
Video corruption, ATI Radeon 7000 and ES1000 - Display Engine stops issuing M...
Status: CLOSED DUPLICATE of bug 182471
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
Blocks: 170416
  Show dependency treegraph
Reported: 2006-02-22 14:44 EST by Rod Macdonald
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-09 05:08:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to eliminate window between MC update and display controller. (2.19 KB, patch)
2006-02-22 17:44 EST, Rod Macdonald
no flags Details | Diff

  None (edit)
Description Rod Macdonald 2006-02-22 14:44:19 EST
This problem was originally reported by Dell.  

Occasionally, on startx, badly corrupted video is displayed completely 
obscuring the desktop.  Ctrl-Alt-Bksp does not resolve the problem - the 
resulting text session remains corrupted.  This has been seen at 1024x768 and 
1280x1024 but it is more prevalent at higher resolutions - it occurs about 20% 
of the time at 1920x1400,24bpp@60Hz when using ES1000 with 200MHz vRAM.  

ATI has determined that the problem is caused by a FIFO which fills, stalling 
the display controller.  This occurs when the memory controller (MC) attempts 
to send transactions to system memory that were intended for the video frame 
buffer.  There is a window of opportunity where the frame buffer address in 
MC_FB_Location differs from the display engine registers.  

There is now a WIP fix available at:

The fix will replace xorg-x11-6.8.1-ati-radeon-RV100-bus-master-fix.patch from 
RH Bug# 165179.  Disabling bus mastering is no longer necessary since the "bad 
transactions" are now stopped closer to the source.

This fix is also mentioned in RH Bug 180150.  

Can you provide a target release for Dell?
Comment 1 Rod Macdonald 2006-02-22 17:44:15 EST
Created attachment 125070 [details]
Patch to eliminate window between MC update and display controller.

This patch is ready to apply to RHEL4 however the xorg patch may be more
up-to-date please review both.
Comment 2 Samuel Benjamin 2006-02-23 11:07:16 EST
I see there are some issues with this patch upstream. Can ATI  investigate and
post a response with the correct patch ?

 ------- Additional comment #3  from Michel Dänzer on 2006-02-23 19:05  [reply]

The current patch has been reported to hang on some systems, see
https://bugzilla.novell.com/show_bug.cgi?id=151631 . This is being investigated.
Comment 3 Mike A. Harris 2006-03-09 05:07:51 EST
Ugh, this bug was filed twice, and people are picking one at random when
updating them.

Comment 4 Mike A. Harris 2006-03-09 05:08:40 EST

*** This bug has been marked as a duplicate of 182471 ***

Note You need to log in before you can comment on or make changes to this bug.