Bug 182499 - Pirut shouldnt close after package installation or removal
Pirut shouldnt close after package installation or removal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 183975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 16:42 EST by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 15:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2006-02-22 16:42:35 EST
Actual results:

After installing packages or removing packages through the search interface,
pirut closes immediately. 


Expected results:

It shouldnt do that
Comment 1 Jeremy Katz 2006-02-22 18:32:45 EST
This is by design.  The entire backend is very much transactional and moving
away from that requires some substantial changes.
Comment 2 Rahul Sundaram 2006-02-22 18:50:48 EST
Can I have this as a enhancement request then?. I am not worried about the
internal design. I would like to install more than one package at a time without
having to reopen pirut everytime. 
Comment 3 Jeremy Katz 2006-02-22 18:57:47 EST
Why are you selecting one at a time instead of selecting a bunch at a time. 

Changing this is something we can look at in the FC6 timeframe, but I'm not 100%
sure how realistic it really is.
Comment 4 Rahul Sundaram 2006-02-22 18:59:49 EST
I search for different things like lets say java and python and then install the
interesting packages one at a time. Lazy cherry picking basically
Comment 5 Jeremy Katz 2006-03-04 11:17:08 EST
*** Bug 183975 has been marked as a duplicate of this bug. ***
Comment 6 Julian Sikorski 2006-03-22 14:19:08 EST
I agree that the current behaviour is not very convenient.
Comment 7 Chris Ricker 2006-03-28 10:28:29 EST
<AOL>"me too"</AOL>

The problem with the current behavior - do one transaction, then exit - is that
IMO usage of a graphical package tool is iterative by nature. That's especially
true with the current default screen being broken into different major
categories -- the usage inclination from the current UI seems to me to be going
into one category, select what you want, apply, then move on to the next category

To me, if I know what packages / groups I want and I just want to start an
install and go, I'd use yum. If I'm bothering to get in the gui, I want
something where I can explore, add stuff one at a time, read the info on each
one, etc.

There's also the practical reason - dependency conflict stuff doesn't display
enough information currently to sanely figure out what's going on, so basically 
your only hope is to do multiple smaller transactions
Comment 8 msevior 2006-04-14 12:54:11 EDT
Me Too.

Please fix this. It totally sucks since it takes about 5 minutes to load.
Comment 9 Rahul Sundaram 2006-04-14 13:44:28 EDT
(In reply to comment #8)
> Me Too.
> 
> Please fix this. It totally sucks since it takes about 5 minutes to load.

Please stop the me too's. It doesnt help anyone and just adds to bugzilla mails
unnecessarily. 
Comment 10 Jeremy Katz 2006-09-13 15:57:36 EDT
Okay, things will no longer exit but you are forced back to the browse view for
now.  While not the best answer, it at least improves things somewhat.

Retaining a visible package list is a lot harder since to get the new state of
the rpmdb, we have to reinitialize some bits of yum which then leaves us with
weird references to no longer existing things.  And it should reduce the hit for
the restart time.

Note You need to log in before you can comment on or make changes to this bug.