Bug 1825228 - DeploymentConfigs absent in the inventory section of Dashboard
Summary: DeploymentConfigs absent in the inventory section of Dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1825975
TreeView+ depends on / blocked
 
Reported: 2020-04-17 12:44 UTC by Olimp Bockowski
Modified: 2020-07-13 17:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: DeploymentConfigs are not included in the inventory section of the project dashboard. Consequence: Users are unable to see at a glance how many DeploymentConfigs are in use in their project. Fix: Add DeploymentConfigs to the inventory section of the project dashboard. Result: Users are able to see how many DeploymentConfigs are in use in their project on the project dashboard.
Clone Of:
: 1825975 1827180 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:28:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
lackOfDeploymentConfig (175.43 KB, image/png)
2020-04-17 12:44 UTC, Olimp Bockowski
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5115 None closed Bug 1825228: Add deployment configs and stateful sets to project ove… 2020-06-23 10:05:36 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:28:54 UTC

Description Olimp Bockowski 2020-04-17 12:44:32 UTC
Created attachment 1679647 [details]
lackOfDeploymentConfig

Description of problem:

In webconsole, when one chooses Developer -> Advanced -> Project Details from the menu on the left and click on the Dashboard tab then, there is an Inventory section. In that Inventory, there is a count of deployments. The DeploymentConfigs, however, are not shown in that inventory. 
Since DeploymentConfig are rather more important for developer than Deployment, it should be rather DC tehre not Deployment?

Version-Release number of selected component (if applicable):
4.3

How reproducible:
create project, then new-app using S2I and then navigate in the web console accordingly

Actual results:
No DeploymentConfig

Expected results:
DeploymentConfig is there

Additional info:
screenshot as an example

Comment 3 shahan 2020-04-21 04:03:54 UTC
Deployment configs shows in the inventory card of project detail page on the developer console.
4.5.0-0.nightly-2020-04-21-003725

Comment 4 errata-xmlrpc 2020-07-13 17:28:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.