Bug 1825975 - DeploymentConfigs absent in the inventory section of Dashboard
Summary: DeploymentConfigs absent in the inventory section of Dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1825228
Blocks: 1827180
TreeView+ depends on / blocked
 
Reported: 2020-04-20 15:46 UTC by Robb Hamilton
Modified: 2020-06-17 22:26 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: DeploymentConfigs were not included in the inventory section of the dashboard. Consequence: The inventory section of the dashboard did not display DeploymentConfigs. Fix: Add DeploymentConfigs to the inventory section of the dashboard. Result: DeploymentConfigs are now included in the inventory section of the dashboard.
Clone Of: 1825228
Environment:
Last Closed: 2020-06-17 22:26:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5122 None closed [release-4.4] Bug 1825975: Add deployment configs and stateful sets to project ove… 2020-06-08 07:37:27 UTC
Red Hat Product Errata RHBA-2020:2445 None None None 2020-06-17 22:26:25 UTC

Description Robb Hamilton 2020-04-20 15:46:33 UTC
+++ This bug was initially created as a clone of Bug #1825228 +++

Description of problem:

In webconsole, when one chooses Developer -> Advanced -> Project Details from the menu on the left and click on the Dashboard tab then, there is an Inventory section. In that Inventory, there is a count of deployments. The DeploymentConfigs, however, are not shown in that inventory. 
Since DeploymentConfig are rather more important for developer than Deployment, it should be rather DC tehre not Deployment?

Version-Release number of selected component (if applicable):
4.3

How reproducible:
create project, then new-app using S2I and then navigate in the web console accordingly

Actual results:
No DeploymentConfig

Expected results:
DeploymentConfig is there

Additional info:
screenshot as an example

Comment 1 Robb Hamilton 2020-05-08 17:22:08 UTC
PR opened, awaiting cherry pick approval.

Comment 2 Robb Hamilton 2020-05-28 19:58:26 UTC
PR opened, awaiting cherry pick approval.

Comment 6 Yadan Pei 2020-06-04 03:33:20 UTC
changes are not in 4.4.0-0.nightly-2020-06-02-202425 yet , will check on newer build

Comment 7 Yanping Zhang 2020-06-08 07:37:21 UTC
Checked on ocp 4.4 cluster with payload: 4.4.0-0.nightly-2020-06-07-075345
Create dc in project. Then go to Project Details page, check on Inventory card, there is "1 Deployment Configs".
The bug is fixed.

Comment 9 errata-xmlrpc 2020-06-17 22:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.