Bug 18255 - APM problem w/ kdm & XFree86 4
APM problem w/ kdm & XFree86 4
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2000-10-03 14:57 EDT by Ian Pilcher
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-11-14 12:40:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2000-10-03 14:57:34 EDT
The following is a copy of bug #12311 at www.kde.org:

I just installed Red Hat 7 (kernel 2.2.16, XFree86 4.0.1, KDE 1.1.2),
and I'm having a strange APM problem.  If kdm is running, and the fore-
ground virtual terminal is not managed by kdm, the system will not

For example, assume my system boots into runlevel 5, and kdm is managing
virtual terminal 7 (display :0).  If I close my laptop (or type "apm -s"
in an xterm) while vt 7 is the foreground vt, the system suspends and
resumes as expected.  If however, I type "apm -s" at a text-mode vt,
the system will not suspend and the following error will start appearing
in the syslog:

    kernel: apm: busy: Unable to enter requested state

This will continue until I switch to vt 7.  As soon as I switch to the
vt that is managed by kdm, the system suspends.

I have seen this problem on both of my systems, an IBM ThinkPad 770Z
with a Trident Cyber9397DVD video chipset and a homegrown desktop with a
Matrox Millenium G200 adapter.  I have only seen this problem with
XFree86 4.0.1; it does not occur with XFree86 3.3.6.

I am reporting this as a kdm bug, because it does not occur when I use
gdm or xdm.
Comment 1 Bernhard Rosenkraenzer 2000-10-04 05:03:21 EDT
It's more likely an XFree86 or kernel problem; normal programs can't prevent the
kernel from suspending.
I suspect the DRM stuff is misbehaving. Doesn't happen on a Gericom 3xC with an
ATI chipset, btw...

Assigning to XFree86
Comment 2 Need Real Name 2000-10-13 14:58:19 EDT
I may have a fix for this...  On my Sharp Actius A150, it would not suspend 
while in the X virtual window.

Going into /etc/sysconfig/apmd, I changed the last line (#LOCK_X=1) to be first 
of all uncommented, and second of all set to zero (LOCK_X=0).  If you look at 
the /etc/sysconfig/apm-scripts/apmscript, I believe you will see that to 
disable the screensaver lock you have to explicitly set it to zero (not simply 
comment it out as it appears the configuration file has tried to do).

I did not check this rigorously, but it seems to have solved the suspend 
problem on my laptop...

Bill @ KilgallonFamily.com
Comment 3 Brian Landers 2000-10-21 23:35:46 EDT
I was having similar problems with APM on my Sony Vaio XG28 laptop (NeoMagic 256
chipset). At first, it would not suspend at all: it would blank the screen, then
hang (forcing a hard reboot). 

From looking at other bug reports, I used Xconfigurator to downgrade to 3.3.6
(running the SVGA server). I am now able to suspend and resume without

Note: this is a vanilla apmd -18 setup, no tweaks to CHANGEVT or LOCK_X.
Comment 4 Dmitri A. Sergatskov 2000-10-26 15:08:11 EDT
I am not sure it is related, but I am having problem setting
DPMS mode with XFree-4.0.
'xset -q' reports DPMS as anabled yet monitor would never go 
into any DPMS modes.
'xset dpms force off' has no effect.
I am running stock Gnome desktop on stock RH7.0.
These all work with RH6.2.
Matrox Mil card / amdk6 system.

Comment 5 Dave Ducharme 2000-11-05 13:30:08 EST
I have the same problem with DPMS mode.  Whether power management is enabled in 
screensaver or directly with 'xset +dpms', there is no effect.  I also am 
running the stock Gnome on RH7.0.

I have recompiled the kernel making sure APM functions are enabled, so it 
doesn't appear to be a kernel fault. I also don't believe it to be an XFree 
4.01 fault, unless it is with RedHat 7.0's implementation of XFree 4.01.

I had been running Mandrake Linux 7.2 which also implements XFree 4.01 and DPMS 
worked in both KDE and Gnome.

Comment 6 Mike A. Harris 2001-07-16 03:42:51 EDT
APM and DPMS are two entirely different things that have absolutely nothing
whatsoever to do with each other.  DPMS in XFree86 works fine.  Any DPMS
problems are in xscreensaver or gnome control center.  This is a frequent
problem which is reported now.  It is not an XFree86 problem.

The APM problem wont be fixed in this release (4.0.1).

Note You need to log in before you can comment on or make changes to this bug.