Bug 182568 - Kernel panic /dev/root not found
Kernel panic /dev/root not found
Status: CLOSED DUPLICATE of bug 182008
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 08:00 EST by Giuseppe Castagna
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 11:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with 2.6.15-1.1826.2.10_FC5 (25.32 KB, text/plain)
2006-02-23 08:00 EST, Giuseppe Castagna
no flags Details
working init file (1.48 KB, text/plain)
2006-02-23 08:09 EST, Giuseppe Castagna
no flags Details
bogus init file (1.50 KB, text/plain)
2006-02-23 08:10 EST, Giuseppe Castagna
no flags Details

  None (edit)
Description Giuseppe Castagna 2006-02-23 08:00:12 EST
Description of problem:

All raw-hide kernels after 2.6.15-1.1826.2.10_FC5 produce a kernel
panic with the following message on the screen (copied by hand)

ata1: dev 0 ATA-7, max UDMA/133, 488397168 sectors: LBA48
nv_sata: Primary device added
nv_sata: Primary device removed
nv_sata: Secondary device added
nv_sata: Secondary device removed
ata1: dev 0 configured for UDMA/133
scsi0 : sata_nv
ata2: SATA link down (SStatus 0)
scsi1 : sata_nv
  Vendor: ATA       Model: HDT722525DLA380   Rev: V44O
  Type:   Direct-Access                      ANSI SCSI revision: 05
Unable to access resume device (/dev/sda9)
mount: could not find filesystem 'dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: eroor mounting /proc: No such file or directory
setuproot: eroor mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!


While 2.6.15-1.1826.2.10_FC5 works perfectly (I'm writing this report from it).
I attached the current dmesg (that is the one with the working
2.6.15-1.1826.2.10_FC5 kernel)

Apparently what happens is that the kernel detect the disc but it does not add
the sda* devices.

I have tried to build a new initrd image for the new kernels by mkintrd but I
obtain the same result.
Comment 1 Giuseppe Castagna 2006-02-23 08:00:12 EST
Created attachment 125100 [details]
dmesg with 2.6.15-1.1826.2.10_FC5
Comment 2 Giuseppe Castagna 2006-02-23 08:08:57 EST
Let me also attach the two init files obtained by doing

 zcat /boot/initrd-2.6.15-1.1826.2.10_FC5.img | cpio -id
 zcat /boot/initrd-2.6.15-1.1975_FC5.img | cpio -id

the first one being the working one, the latter an example of one that does not work
Comment 3 Giuseppe Castagna 2006-02-23 08:09:50 EST
Created attachment 125101 [details]
working init file
Comment 4 Giuseppe Castagna 2006-02-23 08:10:33 EST
Created attachment 125102 [details]
bogus init file
Comment 5 Giuseppe Castagna 2006-02-25 07:43:31 EST
To solve the problem it suffices to create initrd by using mkinitrd with the
option --with=sd_mod. Can somebody explain me why sd_mod is not included by
default in my images?
Comment 6 Peter Jones 2006-02-27 11:17:14 EST

*** This bug has been marked as a duplicate of 182008 ***
Comment 7 Peter Jones 2006-02-27 11:27:56 EST
Can I see the output of mkinitrd when run with the "-v" option?
Comment 8 Giuseppe Castagna 2006-02-27 14:45:13 EST
Here it is

B.



[beppe@lampone ~]$ sudo mkinitrd -v /dev/null 2.6.15-1.1977_FC5
Creating initramfs
Looking for deps of module ide-disk
Looking for deps of module ext3: jbd
Looking for deps of module jbd
Looking for driver for device sda3
Looking for deps of module scsi_mod
Looking for deps of module libata: scsi_mod
Looking for deps of module sata_nv: libata scsi_mod
Looking for driver for device sda9
Using modules:  /lib/modules/2.6.15-1.1977_FC5/kernel/fs/jbd/jbd.ko
/lib/modules/2.6.15-1.1977_FC5/kernel/fs/ext3/ext3.ko
/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/scsi_mod.ko
/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/libata.ko
/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/sata_nv.ko
/sbin/nash -> /tmp/initrd.XT8054/bin/nash
/sbin/insmod.static -> /tmp/initrd.XT8054/bin/insmod
copy from `/lib/modules/2.6.15-1.1977_FC5/kernel/fs/jbd/jbd.ko' [elf64-x86-64]
to `/tmp/initrd.XT8054/lib/jbd.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.15-1.1977_FC5/kernel/fs/ext3/ext3.ko' [elf64-x86-64]
to `/tmp/initrd.XT8054/lib/ext3.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/scsi_mod.ko'
[elf64-x86-64] to `/tmp/initrd.XT8054/lib/scsi_mod.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/libata.ko'
[elf64-x86-64] to `/tmp/initrd.XT8054/lib/libata.ko' [elf64-x86-64]
copy from `/lib/modules/2.6.15-1.1977_FC5/kernel/drivers/scsi/sata_nv.ko'
[elf64-x86-64] to `/tmp/initrd.XT8054/lib/sata_nv.ko' [elf64-x86-64]
Adding module jbd
Adding module ext3
Adding module scsi_mod
Adding module libata
Adding module sata_nv

Note You need to log in before you can comment on or make changes to this bug.