Bug 182008 - sd_mod not added to initrd ->fedora does not boot
sd_mod not added to initrd ->fedora does not boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
: 179588 182568 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-18 18:22 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 13:17:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Initrd verbose log (2.68 KB, text/plain)
2006-03-10 07:31 EST, Ivan Gyurdiev
no flags Details

  None (edit)
Description Ivan Gyurdiev 2006-02-18 18:22:07 EST
The subject says it all. 

NFORCE-CK804: IDE controller at PCI slot 0000:00:06.0
NFORCE-CK804: chipset revision 242
NFORCE-CK804: not 100% native mode: will probe irqs later
NFORCE-CK804: 0000:00:06.0 (rev f2) UDMA133 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA

ata3: SATA link up 3.0 Gbps (SStatus 123)
ata3: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3e01 87:4023 88:407f
ata3: dev 0 ATA-7, max UDMA/133, 390721968 sectors: LBA48

scsi3 : sata_nv
  Vendor: ATA       Model: WDC WD2000JS-55M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05

It will not work without sd_mod... I am using LVM.
Let me know if I need to add something to /etc/modprobe.conf to make it work:

options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias eth0 forcedeth
alias eth1 tulip
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
alias snd-card-1 snd-mpu401
options snd-card-1 index=1
options snd-mpu401 index=1
remove snd-mpu401 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-mpu401
alias char-major-195* nvidia
options nvidia NVreg_ModifyDeviceFiles=0
alias ath0 ath_pci
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
alias char-major-195* nvidia
Comment 1 Peter Jones 2006-02-23 18:27:52 EST
Can you try making a new initrd with mkinitrd-5.0.27-1 from today's rawhide?  I
 it should fix this issue.
Comment 2 Ivan Gyurdiev 2006-02-24 07:20:26 EST
Does not work... new mkinitrd is installed (and verified).
I deleted the previous initrd, re-created it (also tried reinstalling the kernel
pkg).

Modules in the initrd:
======================
dm-mirror.ko  dm-mod.ko  dm-snapshot.ko  dm-zero.ko  ext3.ko  jbd.ko  libata.ko
 sata_nv.ko  scsi_mod.ko
Comment 3 Peter Jones 2006-02-27 11:17:22 EST
*** Bug 182568 has been marked as a duplicate of this bug. ***
Comment 4 Peter Jones 2006-02-27 11:37:16 EST
*** Bug 179588 has been marked as a duplicate of this bug. ***
Comment 5 Peter Jones 2006-02-28 10:36:16 EST
*** Bug 154941 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2006-03-08 13:19:05 EST
This should be fixed now
Comment 7 Ivan Gyurdiev 2006-03-08 13:49:48 EST
Which mkinitrd version?
Comment 8 Ivan Gyurdiev 2006-03-10 07:04:24 EST
AFAICS it is still broken with a verified mkinitrd-5.0.30-1 and kernel 2032. 
This is the newest mkinitrd I see on rawhide. Yes, I did re-create the initrd,
and there is no sd_mod.
Comment 9 Ivan Gyurdiev 2006-03-10 07:13:57 EST
I should point out that this is a volume group that spans two drives - the SATA
drive above, and an older PATA drive, both WD Caviars - I don't know if this is
relevant. If you let me know what information is needed, I can provide it...
Comment 10 Ivan Gyurdiev 2006-03-10 07:31:18 EST
Created attachment 125941 [details]
Initrd verbose log
Comment 11 Giuseppe Castagna 2006-03-10 10:02:07 EST
Ahah, here it is a point in common. I have also a sata drive (Hitachi) and an
older PATA drive (Seagate, I think)

Comment 12 Giuseppe Castagna 2006-03-11 07:45:46 EST
Still broken in kernel 2041
Comment 13 Peter Jones 2006-03-13 13:17:19 EST
OK, I can replicate this problem now -- should be fixed in 5.0.32-1 .

There's a yum repo with it at http://people.redhat.com/pjones/mkinitrd/5.0.32-1/
, please test it so we're sure this is fixed.

Thanks!
Comment 14 Ivan Gyurdiev 2006-03-14 00:33:07 EST
Yes, this corrects the problem...

Note You need to log in before you can comment on or make changes to this bug.