Bug 182603 - sleeping function called from invalid context at arch/powerpc/kernel/traps.c
sleeping function called from invalid context at arch/powerpc/kernel/traps.c
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 183149 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-23 11:57 EST by Orion Poplawski
Modified: 2015-01-04 17:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 17:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-02-23 11:57:25 EST
Description of problem:
Noticed in the kernel logs on the tty4 screen during an install:

<3>Debug: sleeping function called from invalid context at
arch/powerpc/kernel/traps.c:700
<4>in_atomic():0, irqs_disabled():1
<4>Call Trace:
<4>[DEAA3EC0] [C0007A64] show_stack+0x54/0x184 (unreliable)
<4>[DEAA3EE0] [C002B07C] __might_sleep+0xbc/0xd0
<4>[DEAA3EF0] [C000E4CC] program_check_exception+0x218/0x510
<4>[DEAA3F40] [C000FB58] ret_from_except_full+0x0/0x4c
<4>--- Exception: 700 at 0xf29318c
<4>    LR = 0x5293184

How reproducible:
everytime

Steps to Reproduce:
1. boot the boot.iso cdrom in mac mini
Comment 1 Dave Jones 2006-03-06 12:55:46 EST
This rings a bell, I think this got fixed upstream.
Can you grab the latest boot.iso's and test ?
Comment 2 Dave Jones 2006-03-06 12:56:24 EST
*** Bug 183149 has been marked as a duplicate of this bug. ***
Comment 3 Orion Poplawski 2006-03-06 18:10:37 EST
Still seen with today's (2.6.15-1.2009.4.2_FC5)
Comment 4 Dave Jones 2006-03-06 18:34:41 EST
argh, latest kernel from people.redhat.com/davej/kernels/Fedora/devel hasn't
been moved into rawhide for a few days, so the boot.iso hasn't been updated. 
I'll make sure tomorrows gets updated.
Comment 5 Orion Poplawski 2006-03-07 11:42:32 EST
Still present with 2.6.15-1.2025_FC5
Comment 6 David Woodhouse 2006-03-10 07:20:43 EST
was fixed upstream yesterday.
Comment 7 Orion Poplawski 2006-03-14 17:36:04 EST
Confirmed gone.

Note You need to log in before you can comment on or make changes to this bug.