Bug 182619 - pirut fails to open window
pirut fails to open window
Status: CLOSED DUPLICATE of bug 182548
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-23 13:31 EST by Ronny Fischer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 12:10:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2006-02-23 13:31:26 EST
Description of problem:

Trying to open pirut or  system-config-packages results in an error

Version-Release number of selected component (if applicable):

FC5 Test 3

How reproducible:

Always.
Steps to Reproduce:
1.Install and run FC5 Test 3
2.Try opening "Add/Remove Software" or Software Updater
3.
  
Actual results:

An error occurs (see attached file)

Expected results:

Usually there should open a window to choose the software I want to 
install/uninstall.

Additional info:
Comment 1 Jeremy Katz 2006-02-23 13:47:29 EST
Can you attach the error?
Comment 2 Ronny Fischer 2006-02-23 16:22:55 EST
Uhh, sorry. I thougt I did this.
The error is as following:

Component: Software Manager
Summary: TB86fdcb55 repos.py:431:check:RepoError: Cannot find a valid baseurl
for repo: development

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 404, in ?
    main()
  File "/usr/sbin/pirut", line 400, in main
    pm.run()
  File "/usr/sbin/pirut", line 350, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 360, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 131, in reposSetup
    self.doRepoSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 244, in doRepoSetup
    repo.baseurlSetup()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 550, in baseurlSetup
    self.check()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 431, in check
    raise Errors.RepoError, \
RepoError: Cannot find a valid baseurl for repo: development

Local variables in innermost frame:
self: development

BTW, I just noticed that this only happens without an internet connection, e.g.
when I try to install packages from DVD. I think there should be an entry which
points to local resources such CD/DVD media or maybe a local network folder.
Maybe it's possible to configure that at first time start.

thanks so far, 
Comment 3 Jeremy Katz 2006-02-24 12:10:13 EST

*** This bug has been marked as a duplicate of 182548 ***

Note You need to log in before you can comment on or make changes to this bug.