Bug 182645 - 05-udev-early rules needs updating
05-udev-early rules needs updating
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-23 15:39 EST by David Zeuthen
Modified: 2013-03-05 22:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 11:30:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2006-02-23 15:39:50 EST
I'm using

 Kernel 2.6.15-1.1975_FC5
 udev 084-4

It seems this kernel no longer export 'bus' symlinks in sysfs but we didn't
update udev to wait for other files. Result we send the hotplug further up the
stack before the files we need are ready. This means hald pukes on my USB stick

15:36:34.027 [E] util.c:463: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.0/host12/target12:0:0/12:0:0:0/model'
15:36:34.028 [E] util.c:463: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.0/host12/target12:0:0/12:0:0:0/vendor'
15:36:34.029 [E] util.c:322: Cannot open
'/sys/devices/pci0000:00/0000:00:1d.1/usb2/2-2/2-2:1.0/host12/target12:0:0/12:0:0:0/type'

Of course, extra points for fixing the kernel to not send out events before all
sysfs files are actually ready. But I'll settle for some updated udev rules instead.

I'm marking this is a FC5 Blocker as it breaks hotplugging USB sticks. I'm also
marking this as high priority.

Thanks.
Comment 1 David Zeuthen 2006-02-23 15:44:42 EST
Adding kernel folks as this is probably due to kernel ABI 'breakage'
Comment 2 David Zeuthen 2006-02-23 16:24:43 EST
Reverting back to udev-084-1.1 made things work for me.
Comment 3 David Zeuthen 2006-02-23 16:40:37 EST
Changing summary to something more appropriate.
Comment 4 Sammy 2006-02-23 18:06:13 EST
I am seeing the same thing on old kernel FC5test2 kernel on two machines.
Going back to the FC5test2 udev fixes it. It is breaking some scsi stuff
too in addition to usb mouse.
Comment 6 Harald Hoyer 2006-02-24 02:32:32 EST
> Reverting back to udev-084-1.1 made things work for me.

Hmm....

* Tue Jan 24 2006 Harald Hoyer <harald@redhat.com> - 078-7
- put WAIT_FOR_SYSFS rules in 05-udev-early.rules
Comment 7 Harald Hoyer 2006-02-24 02:36:59 EST
Diff from udev-084-1.1 to current udev... This means we have to wait for usb
devices, too, which fails on some devices.

-ACTION=="add", DEVPATH=="/devices/*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="b
us"
+ACTION=="add", DEVPATH=="/devices/*", DEVPATH!="*usb*", ENV{PHYSDEVBUS}=="?*",
 WAIT_FOR_SYSFS="bus"
Comment 8 Harald Hoyer 2006-02-24 02:40:42 EST
> It is breaking some scsi stuff too in addition to usb mouse.

Details please!
Comment 10 Harald Hoyer 2006-02-24 09:04:24 EST
on the other side, there is bug #182723
Comment 11 Harald Hoyer 2006-02-24 11:04:29 EST
and bug #182674

Note You need to log in before you can comment on or make changes to this bug.