Bug 1826820 - OCP/OSP install (v16.1/v4.3.10) using kuryr to deploy octavia results in listeners starting in disabled state
Summary: OCP/OSP install (v16.1/v4.3.10) using kuryr to deploy octavia results in list...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.z
Assignee: Maysa Macedo
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On: 1824258
Blocks: 1829840 1832128 1839835
TreeView+ depends on / blocked
 
Reported: 2020-04-22 15:32 UTC by Maysa Macedo
Modified: 2020-05-25 17:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1824258
: 1839835 (view as bug list)
Environment:
Last Closed: 2020-05-18 13:35:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 216 None closed [release-4.4] Bug 1826820: Ensure LB state annotation sg matches the SG on the LB 2020-08-10 09:45:25 UTC
Red Hat Knowledge Base (Solution) 5038951 None None None 2020-04-30 15:25:44 UTC
Red Hat Product Errata RHBA-2020:2133 None None None 2020-05-18 13:35:23 UTC

Comment 1 Ben Bennett 2020-04-22 16:09:23 UTC
This is not a regression in 4.4.  It's unfortunate to have to ship with the bug, but we can fix it in a 4.4.z stream.

Comment 9 Jon Uriarte 2020-05-11 11:14:45 UTC
Verified in 4.4.0-0.nightly-2020-05-08-224132 on top of OSP 16 compose RHOS_TRUNK-16.0-RHEL-8-20200506.n.2 (with OVS and amphora-driver).

Successfull OCP 4.4 installation.

time="2020-04-29T17:40:25Z" level=info msg="Install complete!"
...
time="2020-04-29T17:40:25Z" level=debug msg="Time elapsed per stage:"
time="2020-04-29T17:40:25Z" level=debug msg="    Infrastructure: 1m42s"
time="2020-04-29T17:40:25Z" level=debug msg="Bootstrap Complete: 18m20s"
time="2020-04-29T17:40:25Z" level=debug msg="               API: 4m37s"
time="2020-04-29T17:40:25Z" level=debug msg=" Bootstrap Destroy: 42s"
time="2020-04-29T17:40:25Z" level=debug msg=" Cluster Operators: 19m32s"
time="2020-04-29T17:40:25Z" level=info msg="Time elapsed: 47m35s"


$ openstack loadbalancer provider list
+---------+-------------------------------------------------+
| name    | description                                     |
+---------+-------------------------------------------------+
| amphora | The Octavia Amphora driver.                     |
| octavia | Deprecated alias of the Octavia Amphora driver. |
+---------+-------------------------------------------------+

$ oc -n openshift-kuryr get pods
NAME                                READY   STATUS    RESTARTS   AGE
kuryr-cni-642gg                     1/1     Running   0          54m
kuryr-cni-dlngj                     1/1     Running   0          44m
kuryr-cni-ht287                     1/1     Running   0          54m
kuryr-cni-j926j                     1/1     Running   0          54m
kuryr-cni-s8z5p                     1/1     Running   0          43m
kuryr-cni-zcck2                     1/1     Running   0          43m
kuryr-controller-6845bb6798-pjmdp   1/1     Running   1          54m

There are no disbaled LBs.

$ openstack loadbalancer listener list --disable -f value | wc -l
0

$ openstack loadbalancer listener list --enable -f value | wc -l
59

Comment 12 errata-xmlrpc 2020-05-18 13:35:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2133


Note You need to log in before you can comment on or make changes to this bug.