Bug 182711 - Doesn't work with Bugzilla v 2.20: no Products found
Doesn't work with Bugzilla v 2.20: no Products found
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Igor Foox
I see that Bugzilla release 2.20 is f...
:
: 185723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 03:23 EST by Wolfi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 10:20:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error dialog when adding a query (9.87 KB, image/png)
2006-03-16 04:55 EST, Wolfi
no flags Details
Error dialog when adding a bug report (10.42 KB, image/png)
2006-03-16 04:56 EST, Wolfi
no flags Details
Apache access log file (948 bytes, text/plain)
2006-03-16 04:57 EST, Wolfi
no flags Details

  None (edit)
Description Wolfi 2006-02-24 03:23:13 EST
Description of problem:
When adding a Bugzilla server that runs version 2.20 or 2.20.1 (and probably
newer versions as well), eclipse-bugzilla is not able to retrieve the products
list from the server.

Version-Release number of selected component (if applicable):
The one available via Eclipse update under http://people.redhat.com/jpound/update

How reproducible:
Just add a Bugzilla BugSystem to the View that connects to a Bugzilla server
running version 2.20+.  Then try to add a Query and you'll see there are no
Products listed to choose from (and no other components either).
Comment 1 Igor Foox 2006-02-24 09:58:50 EST
The version available at the update site is an older version. We are currently
in the process of moving update sites and also updating the version that's
there. I'll post on this bug as soon as we do that so that you can updgrade and
retest.
Comment 2 Andrew Overholt 2006-03-08 09:21:03 EST
Any news here, Igor?
Comment 3 Igor Foox 2006-03-08 09:36:30 EST
Thanks for the reminder Andrew. There is now a new update-site at
http://sourceware.org/eclipse/update , could you try the version there (0.2.2)
and verify if this still occurs?
Comment 4 Wolfi 2006-03-11 12:16:04 EST
(In reply to comment #3)
> Thanks for the reminder Andrew. There is now a new update-site at
> http://sourceware.org/eclipse/update , could you try the version there (0.2.2)
> and verify if this still occurs?

Thanks for the update.  I changed my update site reference to the new location
and updated the bugzilla feature.  Now I get the following exception, when
opening the "Bug Systems" view (see below).  I'm not quite sure whether the
install/update went OK on my machine, as I'm not able to see the Bugzilla
feature in the "Manage Configuration" dialog.

I'll try with a fresh eclipse (3.1.2) installation tomorrow and report back asap!


java.lang.NullPointerException
	at
org.eclipse.team.bugzilla.persistence.ProviderPersistenceAdapter.restore(ProviderPersistenceAdapter.java:65)
	at
org.eclipse.team.bugzilla.persistence.ContainerPersistenceAdapter.restore(ContainerPersistenceAdapter.java:42)
	at
org.eclipse.team.bugzilla.persistence.AbstractPersistenceAdapter.restoreElement(AbstractPersistenceAdapter.java:157)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreChild(PersistenceManager.java:169)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreChildren(PersistenceManager.java:197)
	at
org.eclipse.team.bugzilla.persistence.PersistenceManager.restoreProviders(PersistenceManager.java:138)
	at
org.eclipse.team.bugzilla.BugzillaFactory.getStoredProviders(BugzillaFactory.java:44)
	at
org.eclipse.team.bugs.internal.main.StoredProvidersManager.instantiateStoredProviders(StoredProvidersManager.java:71)
	at
org.eclipse.team.bugs.internal.main.StoredProvidersManager.getStoredProviders(StoredProvidersManager.java:54)
	at org.eclipse.team.bugs.extension.Providers.<init>(Providers.java:91)
	at org.eclipse.team.bugs.extension.Providers.getInstance(Providers.java:46)
	at org.eclipse.team.bugs.internal.views.BugView.createPartControl(BugView.java:53)
	at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:305)
	at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:180)
	at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:552)
	at org.eclipse.ui.internal.Perspective.showView(Perspective.java:1655)
	at org.eclipse.ui.internal.WorkbenchPage.busyShowView(WorkbenchPage.java:937)
	at org.eclipse.ui.internal.WorkbenchPage.access$12(WorkbenchPage.java:920)
	at org.eclipse.ui.internal.WorkbenchPage$13.run(WorkbenchPage.java:3199)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
	at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3196)
	at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3174)
	at org.eclipse.ui.handlers.ShowViewHandler.openView(ShowViewHandler.java:146)
	at org.eclipse.ui.handlers.ShowViewHandler.openOther(ShowViewHandler.java:102)
	at org.eclipse.ui.handlers.ShowViewHandler.execute(ShowViewHandler.java:70)
	at org.eclipse.ui.internal.ShowViewMenu$3.run(ShowViewMenu.java:113)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:996)
	at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
	at
org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
	at
org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1021)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2867)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2572)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
	at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
	at org.eclipse.core.launcher.Main.run(Main.java:973)
	at org.eclipse.core.launcher.Main.main(Main.java:948)
Comment 5 Igor Foox 2006-03-11 14:29:34 EST
Hi Wolfi,

I've seen this error before, it is because of some changes to the persistence
layer (how we store information about bugs you viewed). Unfortunately it's a bit
flaky, it happens sometimes, but not always. 
I believe that if you close Eclipse, and then reopen it then this issue should
go away. If it this doesn't help, please try running it with a new workspace and
adding opening the Bugs View. Please let me know how this works. If you cannot
make it work in your old workspace then please let me know here. Reinstalling a
fresh Eclipse is a pretty drastic measure, and I think is unneeded in this case.
Comment 6 Igor Foox 2006-03-11 14:30:21 EST
Andrew, could you please reassign the bug to me?
Comment 7 Igor Foox 2006-03-14 10:42:35 EST
FYI I fixed the bug that gave you the NullPointerException, this should be in
the next release. 

Could you also verify whether the solution above solved this problem for you?
Comment 8 Wolfi 2006-03-15 12:22:50 EST
Hi Igor,

sorry for the delay, I have been abroad for a couple of days.
I'll test the NullPointerException case tomorrow, when I'm back at the office.

Meanwhile, I tried version 0.2.2 on a fresh (and thus nearly empty) installation
of Bugzilla 2.20.1, on eclipse 3.1.2 (an installation that never saw the
bugzilla plugin before) on Linux (FC3) and can confirm that it works.

I can't see the "Classifications", though, but I assume, this is not (yet?)
supported, being a rather new bugzilla feature.
Comment 9 Igor Foox 2006-03-15 13:04:11 EST
Hi Wolfi,

Thanks for testing, I'm glad it works. I am going to close this bug for now
since the problem is resolved. Please let me know if this returns.

You're right, Classifications are not supported yet. This is most evident with
the eclipse.org bugzilla which is pretty broken without classification ( see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179180). We are working on
this and I hope this will be solved within a week or two, please look at the
website for announcements of a new version.
Comment 10 Wolfi 2006-03-16 04:54:23 EST
Hi Igor,

I made the tests in my other environment at work (Windows, eclipse 3.1.1), using
bugzilla plugin 0.2.2, using a new workspace, as you suggested:
  - the view openes now without exception.
  - I am able to add a bug system connected to my bugzilla 2.20.1 installation.
  - I still don't see any products or other elements, e.g. bug properties in the
    "Advanced" mode of the "Add Query" dialog.
  - I get error messages when trying to add a bug# (Add > Bug Report... and
    Add > Query...).

I'll attach screenshots of the dialog boxes and the relevant parts of my web
server's (apache) access log.
Comment 11 Wolfi 2006-03-16 04:55:35 EST
Created attachment 126209 [details]
Error dialog when adding a query
Comment 12 Wolfi 2006-03-16 04:56:29 EST
Created attachment 126210 [details]
Error dialog when adding a bug report
Comment 13 Wolfi 2006-03-16 04:57:23 EST
Created attachment 126211 [details]
Apache access log file
Comment 14 Wolfi 2006-03-16 05:05:42 EST
Hi again,

Found it!

I investigated things a little further.  I had this working on my other
installation, but not on this one, so I suspected some Bugzilla configuration
issue being the cause.  And so it was:

The "requirelogin" parameter has to be set to "off" or "no" for this to work.

Although you provide login information input fields in the "Add Bugsystem"
dialog, they seem to address different things.   Should this be made an issue of
its own?
Comment 15 Igor Foox 2006-03-16 09:05:42 EST
Hi Wolfi,

Thanks for the informative analysis. The bugzilla plugin currently does not
support logging into a bugzilla because it doesn't support any operations that
usually require it (i.e. adding a bug, changing a bug, etc.). Most public
bugzilla installations do not require you to log in in order to view bugs, so
the plugin work.

The fields in the Add Bug System dialog are experimental (and there's a warning
about this), and currently only work with the Red Hat bugzilla (this one). The
reason being that the Red Hat bugzilla has an implementation of an XML-RPC
interface that allows me to easily implement complex operations, for other
bugzillas we need to use screen scraping for that. There is an effort to get
this sort of support into the upstream bugzilla
(https://bugzilla.mozilla.org/show_bug.cgi?id=224577), but it's not there yet.

Is there any particular compelling reason that you need to be able to have
login=on? If it's important I will see how difficult that would be to implement.
Comment 16 Wolfi 2006-03-17 03:26:18 EST
(In reply to comment #15)

Hi Igor,

thanks for your clarification.

I feel, an XML-RPC interface would be an important addition to Bugzilla.
I am using a "bridge" between my version control (subversion) and bugzilla, but
it's rather a kludge, parsing URLs, hacking together HTTP POSTs and so, and very
much bugzilla version dependent...

> Is there any particular compelling reason that you need to be able to have
> login=on? If it's important I will see how difficult that would be to implement.

No reason, at least not now, as we're using bugzilla internally, in a non-routed
subnet only.  So I simply changed settings to requirelogin=off and it's OK for now.

Well, thanks a lot for your help!
Comment 17 Igor Foox 2006-03-17 10:20:33 EST
Hi Wolfi,

Glad to help, let me know if you have any other problems.
Comment 18 Kyu Lee 2006-08-30 11:55:02 EDT
*** Bug 185723 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.