Bug 1828174 - Azure: ProvisioningFailed: Failed to provision volume; The resource does not support availability zones at location 'westus'.
Summary: Azure: ProvisioningFailed: Failed to provision volume; The resource does not ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Tomas Smetana
QA Contact: Qin Ping
URL:
Whiteboard:
: 1829312 1830324 (view as bug list)
Depends On:
Blocks: 1852938 1855436
TreeView+ depends on / blocked
 
Reported: 2020-04-27 08:35 UTC by Tomas Smetana
Modified: 2020-07-13 17:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Volume provisioning in Azure clusters that were created without availability zones support might failed with the default storage class. Consequence: The volumes might fail to provision in certain Azure region while the same configuration worked elsewhere. Fix: The availability zone support is detected during provisioning. Result: The volumes should provision in all the Azure regions now.
Clone Of:
Environment:
[sig-storage] In-tree Volumes [Driver: azure-disk] [Testpattern: Pre-provisioned PV (default fs)] volumes should allow exec of files on the volume
Last Closed: 2020-07-13 17:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24933 None closed Bug 1828174: Fix azure tests in unzoned environment 2020-08-03 06:29:20 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:31:56 UTC

Description Tomas Smetana 2020-04-27 08:35:30 UTC
The Azure tests fail when trying to provision a disk in region that doesn't support availability zones:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.4/1548

Apr 26 22:06:59.029: INFO: At 2020-04-26 22:01:58 +0000 UTC - event for pvc-dncs2: {persistentvolume-controller } ProvisioningFailed: Failed to provision volume with StorageClass "e2e-topology-7123-azure-scg9bkm": compute.DisksClient#CreateOrUpdate: Failure sending request: StatusCode=400 -- Original Error: Code="LocationNotSupportAvailabilityZones" Message="The resource 'Microsoft.Compute/disks/ci-op-d8m3l54f-761c8-sklhf-dynamic-pvc-7ab0c46d-a9e0-4743-b25e-3f95ce0dd83d' does not support availability zones at location 'westus'."

We probably should try to detect this type of error and make it non-failing for the test.

Comment 4 Gabe Montero 2020-04-28 13:59:52 UTC
As part of build cop duties today 
I see in https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.5/958

    Retriable: false, RetryAfter: 0s, HTTPStatusCode: 400, RawError: Retriable: false, RetryAfter: 0s, HTTPStatusCode: 400, RawError: {"error":{"code":"LocationNotSupportAvailabilityZones","message":"The resource 'Microsoft.Compute/disks/e2e-7c3fcdda-299f-43f3-a10b-991498f7d5a7' does not support availability zones at location 'westus'."}}

For test 

[sig-storage] In-tree Volumes [Driver: azure-disk] [Testpattern: Inline-volume (ext4)] volumes should store data [Suite:openshift/conformance/parallel] [Suite:k8s] expand_more

checkout https://search.svc.ci.openshift.org/?search=Microsoft.Compute&maxAge=48h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job

Comment 5 Michael Gugino 2020-04-29 02:36:46 UTC
This is totally blocking CI and needs to be prioritized downstream ASAP.

Comment 7 Jan Safranek 2020-04-29 12:42:56 UTC
*** Bug 1829312 has been marked as a duplicate of this bug. ***

Comment 10 Clayton Coleman 2020-05-07 00:20:04 UTC
*** Bug 1832627 has been marked as a duplicate of this bug. ***

Comment 11 W. Trevor King 2020-05-07 03:50:34 UTC
*** Bug 1830324 has been marked as a duplicate of this bug. ***

Comment 12 Qin Ping 2020-05-11 12:26:27 UTC
This is a cluster run in westus region: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-4.5/1119

No this issue found, so marked this bug as verified.

Comment 13 errata-xmlrpc 2020-07-13 17:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.