Bug 1852938 - [release-4.4] Fix azure tests in unzoned environment [NEEDINFO]
Summary: [release-4.4] Fix azure tests in unzoned environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Christian Huffman
QA Contact: Wei Duan
URL:
Whiteboard:
: 1852955 1855436 (view as bug list)
Depends On: 1828174
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-01 15:49 UTC by Corey Daley
Modified: 2020-08-25 06:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
[sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (delayed binding)] topology [Top Level] [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (delayed binding)] topology should provision a volume and schedule a pod with AllowedTopologies [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (immediate binding)] topology [Top Level] [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (immediate binding)] topology should provision a volume and schedule a pod with AllowedTopologies
Last Closed: 2020-08-25 06:20:31 UTC
Target Upstream Version:
wduan: needinfo? (chuffman)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25262 None closed [release-4.4] Bug 1852938: Fix azure tests in unzoned environment 2020-11-20 08:01:42 UTC
Red Hat Product Errata RHBA-2020:3440 None None None 2020-08-25 06:20:38 UTC

Comment 2 Jan Safranek 2020-07-01 18:18:14 UTC
*** Bug 1852955 has been marked as a duplicate of this bug. ***

Comment 3 Bowen Song 2020-07-07 21:21:59 UTC
Isn't this same as https://bugzilla.redhat.com/show_bug.cgi?id=1852924 ?

Comment 5 Christian Huffman 2020-07-09 20:39:38 UTC
*** Bug 1855436 has been marked as a duplicate of this bug. ***

Comment 7 Steve Kuznetsov 2020-07-22 22:09:38 UTC
ALso

[sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (default fs)] subPath [Top Level] [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (default fs)] subPath should support file as subpath [LinuxOnly]
[sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (ext4)] volumes [Top Level] [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (ext4)] volumes should allow exec of files on the volume
[sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (default fs)] volumes [Top Level] [sig-storage] In-tree Volumes [Driver: azure] [Testpattern: Dynamic PV (default fs)] volumes should store data

Comment 10 Wei Duan 2020-08-03 09:29:38 UTC
I checked the related cases passed recently, but all in region "centralus", I'd like to wait some days to check case passed in region "westus".

Comment 11 Wei Duan 2020-08-06 10:33:48 UTC
Hi Huffman,

As e2e did not be triggered in "westus", I test it from our side but I did not reproduce this issue in our test env successfully on both 4.4.14 (without fix) and 4.4.16 Candidate nightly (with fix).

In our test env, I set up 3 master + 2 worker in region "westus",  pv were attached and mounted successfully.
A. From the Aure portal, all nodes have "Availability zone": "NA", and the mounted volumes have "Availability zone":None.
B. From the oc get info, all nodes have Labels: "topology.kubernetes.io/region=westus" and "topology.kubernetes.io/zone=0", and the mounted volumes only have "region=westus" for nodeSelector in nodeAffinity.


Is it because our flexy installation added the label for "Availability zone", so I could not reproduce? Or something I missed?

Comment 15 Wei Duan 2020-08-11 03:11:25 UTC
I see in some azure dynamic case failed in the latest test, but from the log, it is a different failure on region centralus.
https://prow.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-azure-ovn-4.4/1292870227733778432

Comment 18 errata-xmlrpc 2020-08-25 06:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3440


Note You need to log in before you can comment on or make changes to this bug.