Bug 1829030 - Masthead dropdown items have irregular spacing
Summary: Masthead dropdown items have irregular spacing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1828588
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-28 18:08 UTC by Robb Hamilton
Modified: 2020-06-29 15:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Upstream code changes in PatternFly resulted in the spacing between masthead dropdown items to be incorrect. Consequence: The spacing between masthead dropdown items is larger than it should be. Fix: Remove a previously applied fix so the correct spacing value is inherited from PatternFly. Result: The spacing between masthead dropdown items is correct.
Clone Of: 1828588
Environment:
Version: 4.5.0-0.ci-2020-04-27-100805 Cluster ID: 48915443-e743-40bf-a93d-91b7e5d49174 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.122 Safari/537.36
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5219 None closed [release-4.4] Bug 1829030: Fix bug where masthead dropdown item spacing is inconsi… 2020-06-26 16:29:35 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:08 UTC

Description Robb Hamilton 2020-04-28 18:08:42 UTC
+++ This bug was initially created as a clone of Bug #1828588 +++

Description of problem:  Spacing between separator and first item in following group is off in masthead dropdowns.


Version-Release number of selected component (if applicable):  4.5


How reproducible:  Always


Steps to Reproduce:
1.  Click the help dropdown in the masthead
2.  Note "Learning Portal" is closer to the separator than "About"

Comment 1 Robb Hamilton 2020-05-08 17:16:18 UTC
PR opened, awaiting cherry pick approval.

Comment 2 Robb Hamilton 2020-05-28 19:55:19 UTC
PR opened, awaiting cherry pick approval.

Comment 3 Robb Hamilton 2020-06-17 18:42:44 UTC
PR opened, awaiting cherry pick approval.

Comment 6 shahan 2020-06-22 03:37:18 UTC
I did not find learning portal on 4.4, do we support it on 4.4?

Comment 7 Robb Hamilton 2020-06-22 12:42:03 UTC
The bug also occurs at mobile in the masthead kebab dropdown, so you can verify it there for 4.4.

Comment 8 shahan 2020-06-23 03:01:30 UTC
Thanks, Robb.

The masthead dropdown item spacing is consistent.
4.4.0-0.nightly-2020-06-21-210301

Comment 10 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.