Bug 1829233 - DNS LB not allowing UDP traffic after Octavia upgrade
Summary: DNS LB not allowing UDP traffic after Octavia upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks: 1841029
TreeView+ depends on / blocked
 
Reported: 2020-04-29 09:17 UTC by Maysa Macedo
Modified: 2020-07-13 17:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1841029 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:32:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 607 0 None closed Bug 1829233: Recreate DNS service upon Octavia upgrade 2020-06-29 16:46:33 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:47 UTC

Description Maysa Macedo 2020-04-29 09:17:08 UTC
Description of problem:

In case Octavia is upgraded from OSP13 to OSP16, the support for UDP listener becomes available and the webhook that enforces DNS resolution over TCP is removed from the cluster. In order to ensure the DNS resolution is working fine for any new pod that gets created the DNS service must be recreated so the UDP listeners becomes available on the new amphora.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Upgrade Octavia from OSP13 to OSP16 with amphora
2. Verify the Kuryr Controller keeps retrying to add pool on a load balancer with old amphora and as not allowed keeps restarting
3.

Actual results:


Expected results:


Additional info:

Comment 3 rlobillo 2020-06-02 09:07:21 UTC
Octavia component update should be part of OSP13 to OSP16 upgrade which is not supported at the moment, so QE verification only confirms that the fix code is present on 4.5.0-0.nightly-2020-05-29-005153

Comment 4 errata-xmlrpc 2020-07-13 17:32:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.