Bug 1841029 - DNS LB not allowing UDP traffic after Octavia upgrade
Summary: DNS LB not allowing UDP traffic after Octavia upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1829233
Blocks: 1846459
TreeView+ depends on / blocked
 
Reported: 2020-05-28 07:57 UTC by Maysa Macedo
Modified: 2020-06-23 00:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Upon Octavia upgrade from OpenStack 13 to 16, UDP listener is supported and the strategy to enforce DNS resolution over TCP protocol is removed, requiring that the existent DNS service that specifies UDP protocol has the new listener added. Consequence: The already existent DNS load-balancer have an old amphora image which does not support the new listener causing the listener creation to fail. Fix: The DNS OpenShift service that requires UDP is recreated, causing a recreation of the load balancer with the new Amphora version. The recreation of the service and load balancer cause some down time on the DNS resolution. Result: The load balancer for the DNS service is created with all the needed listeners.
Clone Of: 1829233
: 1846459 (view as bug list)
Environment:
Last Closed: 2020-06-23 00:57:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 653 None closed Bug 1841029: Recreate DNS service upon Octavia upgrade 2020-07-03 08:39:50 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:45 UTC

Comment 4 rlobillo 2020-06-15 16:12:42 UTC
Octavia component update should be part of OSP13 to OSP16 upgrade which is not supported at the moment, so QE verification only confirms that the fix code is present on 4.4.0-0.nightly-2020-06-14-142924.

$ podman pull --authfile secrets.json registry.svc.ci.openshift.org/ocp/release:4.4.0-0.nightly-2020-06-14-142924
$ podman run -it registry.svc.ci.openshift.org/ocp/release:4.4.0-0.nightly-2020-06-14-142924 image cluster-network-operator
$ podman pull --authfile secrets.json quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:1e3e7c67e0ee2faef9952f5eac3e637d33a621b5349f2c7b99a93df4a4178236
$ podman inspect fec568f0a4794e166cb2a56af146f13997f68b402401edb7e254580e42db7101 | grep commit
                "io.openshift.build.commit.id": "7f0a485dbdaa7049e889484713f9325dd3259e9c",
                "io.openshift.build.commit.url": "https://github.com/openshift/cluster-network-operator/commit/7f0a485dbdaa7049e889484713f9325dd3259e9c",
            "io.openshift.build.commit.id": "7f0a485dbdaa7049e889484713f9325dd3259e9c",
            "io.openshift.build.commit.url": "https://github.com/openshift/cluster-network-operator/commit/7f0a485dbdaa7049e889484713f9325dd3259e9c",

Confirmed that HEAD commit of target nightly release is above fix code: https://github.com/openshift/cluster-network-operator/commits/release-4.4

Comment 6 errata-xmlrpc 2020-06-23 00:57:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.