Bug 1829567 - Pipeline Builder Misunderstands Task 'default' Empty Value
Summary: Pipeline Builder Misunderstands Task 'default' Empty Value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1829568
TreeView+ depends on / blocked
 
Reported: 2020-04-29 19:21 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Pipeline Builder incorrectly interpreted a default value of an empty string ('') as having no default. Consequence: Some operator provided tasks needed this to be the default and thus will have issues working without it. Fix: Check for a default property and not assume the validity of the value. Result: Should be able to respect anything the OpenShift Pipeline Operator deems as a valid default value.
Clone Of:
: 1829568 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline Builder Understands Task 'default' Empty Value (32.90 KB, image/png)
2020-05-27 15:12 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5235 None closed Bug 1829567: Pipeline Builder treats task param default properly 2020-06-30 18:21:28 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:33:14 UTC

Description Andrew Ballantyne 2020-04-29 19:21:54 UTC
Description of problem:
Default value of an empty string is treated as not having a default value.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to the Pipeline Builder
2. Add the `maven` task
3. Click on the task bubble

Actual results:
Failure to understand which are required (none are)

Expected results:
No fields in the `maven` task should be required as they all have default values

Additional info:
Applies to all Task params that have a default value of an empty string

Comment 4 spathak@redhat.com 2020-05-27 15:12:25 UTC
Created attachment 1692741 [details]
Pipeline Builder Understands Task 'default' Empty Value

Comment 5 spathak@redhat.com 2020-05-27 15:13:01 UTC
Validated on build version: 4.5.0-0.nightly-2020-05-27-000432
Browser version: Firefox 73

Comment 6 errata-xmlrpc 2020-07-13 17:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.