Bug 1829568 - Pipeline Builder Misunderstands Task 'default' Empty Value
Summary: Pipeline Builder Misunderstands Task 'default' Empty Value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.z
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1829567
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 19:23 UTC by Andrew Ballantyne
Modified: 2020-06-29 15:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Pipeline Builder incorrectly interpreted a default value of an empty string ('') as having no default. Consequence: Some operator provided tasks needed this to be the default and thus will have issues working without it. Fix: Check for a default property and not assume the validity of the value. Result: Should be able to respect anything the OpenShift Pipeline Operator deems as a valid default value.
Clone Of: 1829567
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5545 None closed Bug 1829568: Pipeline Builder treats task param default properly 2020-06-26 16:29:27 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:08 UTC

Description Andrew Ballantyne 2020-04-29 19:23:19 UTC
+++ This bug was initially created as a clone of Bug #1829567 +++

Description of problem:
Default value of an empty string is treated as not having a default value.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to the Pipeline Builder
2. Add the `maven` task
3. Click on the task bubble

Actual results:
Failure to understand which are required (none are)

Expected results:
No fields in the `maven` task should be required as they all have default values

Additional info:
Applies to all Task params that have a default value of an empty string

Comment 4 Gajanan More 2020-06-22 06:37:07 UTC
I have validated the bugzilla on the 
Build: 4.4.0-0.ci-2020-06-21-200906
Browser: Google Chrome 81.0.4044.129
Marking this as verified.

Comment 6 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.