Bug 183004 - Clicking Help crashes Sprog
Clicking Help crashes Sprog
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Sprog (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 00:19 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: Sprog-0.14-7.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 17:54:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-02-25 00:19:00 EST
Description of problem:
Clicking Help crashes Sprog

Version-Release number of selected component (if applicable):

Sprog-0.14-6.fc5

How reproducible:
Everytime

Steps to Reproduce:
1. open terminal 
2. sprog
3. go to Help menu, click "Contents"
  
Actual results:
Crash:
Base class package "Pod::Simple::Methody" is empty.
    (Perhaps you need to 'use' the module which defines that package first.)
 at /usr/lib/perl5/vendor_perl/5.8.8/Sprog/HelpParser.pm line 6
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.8/Sprog/HelpParser.pm line 8.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.8/Sprog/ClassFactory.pm line 61.
 at /usr/lib/perl5/vendor_perl/5.8.8/Sprog/GtkView/HelpViewer.pm line 318
 at /usr/lib/perl5/vendor_perl/5.8.8/Sprog/GtkView/HelpViewer.pm line 318

Expected results:
Help browser should be displayed

Additional info:
Comment 1 Gavin Henry 2006-02-25 04:58:46 EST
Looks like Pod::Simple::Methody isn't installed.

Not picked up either as a requirement and maybe somethign I'll need to package
up and get into extras.

Give me the weekend to try a few things.

Gavin.
Comment 2 Alex Lancaster 2006-02-25 05:13:29 EST
(In reply to comment #1)
> Looks like Pod::Simple::Methody isn't installed.
> 
> Not picked up either as a requirement and maybe somethign I'll need to package
> up and get into extras.

Thanks for looking into it.

> Give me the weekend to try a few things.

While you're at it, any chance for that FC-4 build ;-) : bug #182461 and
associated requires: (bug #182455, bug #182458, bug #182459, it looks like they
all failed their FC-4 builds a couple of days ago). 


Comment 3 Gavin Henry 2006-02-25 17:10:50 EST
Try it now. There was a build req of Pod Simple, but that might not have pulled
in Pod::Simple::Methody, however the RPM perl-Pod-Simple has it, so I've made
that a Require.

Gavin.
Comment 4 Alex Lancaster 2006-02-25 18:33:43 EST
Will do as soon as package is pushed on and repos.
Comment 5 Ralf Corsepius 2006-02-26 02:47:22 EST
Please use
Requires: perl(Pod::Simple::Methody)
instead of Requires: perl-Simple-Pod

Comment 6 Gavin Henry 2006-02-26 04:32:00 EST
Yes, but perl-Simple-Pod is the RPM. Is that not the correct way to do it then?

Gavin.
Comment 7 Alex Lancaster 2006-02-26 14:26:04 EST
Works on development, can you backport this change to the FC-4 branch in CVS,
then I can close the bug.
Comment 8 Alex Lancaster 2006-02-26 14:28:56 EST
(In reply to comment #6)
> Yes, but perl-Simple-Pod is the RPM. Is that not the correct way to do it then?

A Requires does not necessarily have to be the name of the RPM, it can be a
shared library or a virtual requires like perl(Pod::Simple::Methody) or the ones
you have in your BuildRequires.  rpm/yum can figure out the actual package name
from this info.

Comment 9 Gavin Henry 2006-02-26 16:41:59 EST
Done.
Comment 10 Alex Lancaster 2006-02-26 17:54:32 EST
OK, hopefully this will work for FC-4 when Sprog is rebuilt.  Closing.

Note You need to log in before you can comment on or make changes to this bug.