Bug 183021 - glibc detected /sbin/grubby munmap_chunk(): invalid pointer: 0x00007fff
glibc detected /sbin/grubby munmap_chunk(): invalid pointer: 0x00007fff
Status: CLOSED DUPLICATE of bug 183010
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 08:59 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 18:11:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2006-02-25 08:59:04 EST
Description of problem:
glibc error reported while installing kernel (obtained from
http://people.redhat.com/davej/kernels/Fedora/devel/ )

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1980_FC5.x86_64.rpm
grub-0.97-3

How reproducible:
reproducable with: rpm -ivh --replacepkgs kernel-2.6.15-1.1980_FC5.x86_64.rpm
kernel-devel-2.6.15-1.1980_FC5.x86_64.rpm

Steps to Reproduce:
1.rpm -ivh kernel-2.6.15-1.1980_FC5.x86_64.rpm kernel-devel
-2.6.15-1.1980_FC5.x86_64.rpm
2.
3.
  
Actual results:
Preparing...                ########################################### [100%]
   1:kernel-devel           ########################################### [ 50%]
   2:kernel                 ########################################### [100%]
*** glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer: 0x00007fff
fffd5a90 ***
======= Backtrace: =========
/lib64/libc.so.6(__libc_free+0x17a)[0x30f1c6d9fa]
/sbin/grubby[0x408746]
/sbin/grubby[0x4088a3]
/sbin/grubby[0x409892]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x30f1c1d024]
/sbin/grubby[0x402bc9]
======= Memory map: ========
00400000-00442000 r-xp 00000000 fd:00 65208409                           /sbin/g
rubby
00541000-00545000 rw-p 00041000 fd:00 65208409                           /sbin/g
rubby
00545000-005c8000 rw-p 00545000 00:00 0                                  [heap]
30f0f00000-30f0f19000 r-xp 00000000 fd:00 21659654                       /lib64/
ld-2.3.90.so
30f1019000-30f101a000 r--p 00019000 fd:00 21659654                       /lib64/
ld-2.3.90.so
30f101a000-30f101b000 rw-p 0001a000 fd:00 21659654                       /lib64/
ld-2.3.90.so
30f1c00000-30f1d32000 r-xp 00000000 fd:00 21659657                       /lib64/
libc-2.3.90.so
30f1d32000-30f1e31000 ---p 00132000 fd:00 21659657                       /lib64/
libc-2.3.90.so
30f1e31000-30f1e35000 r--p 00131000 fd:00 21659657                       /lib64/
libc-2.3.90.so
30f1e35000-30f1e36000 rw-p 00135000 fd:00 21659657                       /lib64/
libc-2.3.90.so
30f1e36000-30f1e3b000 rw-p 30f1e36000 00:00 0
30f3900000-30f390d000 r-xp 00000000 fd:00 21659678                       /lib64/
libgcc_s-4.1.0-20060219.so.1
30f390d000-30f3a0c000 ---p 0000d000 fd:00 21659678                       /lib64/
libgcc_s-4.1.0-20060219.so.1
30f3a0c000-30f3a0d000 rw-p 0000c000 fd:00 21659678                       /lib64/
libgcc_s-4.1.0-20060219.so.1
2aeacfcb1000-2aeacfcb2000 rw-p 2aeacfcb1000 00:00 0
2aeacfcd7000-2aeacfcd9000 rw-p 2aeacfcd7000 00:00 0
7ffffffc4000-7ffffffda000 rw-p 7ffffffc4000 00:00 0                      [stack]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0                  [vdso]
/sbin/new-kernel-pkg: line 89: 22056 Aborted                 /sbin/grubby --add-
kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default $makedefault --ti
tle "$title" ${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbarg
s"} --args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$title"


Expected results:


Additional info:
Comment 1 John Ellson 2006-02-25 09:15:03 EST
Same problem occurs with the older grub-0.97-2.1
Comment 2 Bernard Johnson 2006-02-25 16:26:34 EST
This is also a problem with i386 arch.
Comment 3 Dave Jones 2006-02-26 18:11:20 EST

*** This bug has been marked as a duplicate of 183010 ***

Note You need to log in before you can comment on or make changes to this bug.