Bug 183010 - grubby blows up on kernel install
grubby blows up on kernel install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
: 183011 183021 183079 183241 183312 183319 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-25 02:35 EST by Dave Jones
Modified: 2015-01-04 17:25 EST (History)
11 users (show)

See Also:
Fixed In Version: 5.0.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 11:14:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-02-25 02:35:51 EST
(02:36:26:davej@delerium:~)$ sudo rpm -ivh kernel-smp-2.6.15-1.1980_FC5.i686.rpm
Preparing...                ########################################### [100%]
   1:kernel-smp             ########################################### [100%]
*** glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer: 0xbfff5ba0 ***
======= Backtrace: =========
/lib/libc.so.6(__libc_free+0x17b)[0x1783ef]
/sbin/grubby[0x804fd12]
/sbin/grubby[0x804fe73]
/sbin/grubby[0x8050c9e]
/lib/libc.so.6(__libc_start_main+0xdc)[0x1267a4]
/sbin/grubby[0x804a001]
======= Memory map: ========
00111000-00234000 r-xp 00000000 fd:00 1703958    /lib/libc-2.3.90.so
00234000-00237000 r-xp 00122000 fd:00 1703958    /lib/libc-2.3.90.so
00237000-00238000 rwxp 00125000 fd:00 1703958    /lib/libc-2.3.90.so
00238000-0023b000 rwxp 00238000 00:00 0
0059d000-005b6000 r-xp 00000000 fd:00 1703951    /lib/ld-2.3.90.so
005b6000-005b7000 r-xp 00018000 fd:00 1703951    /lib/ld-2.3.90.so
005b7000-005b8000 rwxp 00019000 fd:00 1703951    /lib/ld-2.3.90.so
00ad5000-00ae0000 r-xp 00000000 fd:00 1704110    /lib/libgcc_s-4.1.0-20060219.so.1
00ae0000-00ae1000 rwxp 0000a000 fd:00 1704110    /lib/libgcc_s-4.1.0-20060219.so.1
00fab000-00fac000 r-xp 00fab000 00:00 0          [vdso]
08048000-08089000 r-xp 00000000 fd:00 11206826   /sbin/grubby
08089000-0808c000 rw-p 00041000 fd:00 11206826   /sbin/grubby
0808c000-08094000 rw-p 0808c000 00:00 0
0909c000-090f7000 rw-p 0909c000 00:00 0          [heap]
b7feb000-b7fec000 rw-p b7feb000 00:00 0
b7ff8000-b7ff9000 rw-p b7ff8000 00:00 0
bffe3000-bfff9000 rw-p bffe3000 00:00 0          [stack]
/sbin/new-kernel-pkg: line 89:  5777 Aborted                 (core dumped)
/sbin/grubby --add-kernel=$bootPrefix/$kernelName-$version $INITRD
--copy-default $makedefault --title "$title"
${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbargs"}
--args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$title"
Comment 1 Nicolas Mailhot 2006-02-25 07:44:59 EST
Same here (x86_64) :

  Updating  : mkinitrd                     ##################### [ 17/104]
  Installing: kernel                       ##################### [ 18/104]
*** glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer:
0x00007fffffd016f0 ***
======= Backtrace: =========
/lib64/libc.so.6(__libc_free+0x17a)[0x3cd826d9fa]
/sbin/grubby[0x408746]
/sbin/grubby[0x4088a3]
/sbin/grubby[0x409892]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x3cd821d024]
/sbin/grubby[0x402bc9]
======= Memory map: ========
00400000-00442000 r-xp 00000000 fd:00 2523247                           
/sbin/grubby
00541000-00545000 rw-p 00041000 fd:00 2523247                           
/sbin/grubby
00545000-005ab000 rw-p 00545000 00:00 0                                  [heap]
3cd8000000-3cd8019000 r-xp 00000000 fd:00 393282                        
/lib64/ld-2.3.90.so
3cd8119000-3cd811a000 r--p 00019000 fd:00 393282                        
/lib64/ld-2.3.90.so
3cd811a000-3cd811b000 rw-p 0001a000 fd:00 393282                        
/lib64/ld-2.3.90.so
3cd8200000-3cd8332000 r-xp 00000000 fd:00 393408                        
/lib64/libc-2.3.90.so
3cd8332000-3cd8431000 ---p 00132000 fd:00 393408                        
/lib64/libc-2.3.90.so
3cd8431000-3cd8435000 r--p 00131000 fd:00 393408                        
/lib64/libc-2.3.90.so
3cd8435000-3cd8436000 rw-p 00135000 fd:00 393408                        
/lib64/libc-2.3.90.so
3cd8436000-3cd843b000 rw-p 3cd8436000 00:00 0
3cddd00000-3cddd0d000 r-xp 00000000 fd:00 393442                        
/lib64/libgcc_s-4.1.0-20060219.so.1
3cddd0d000-3cdde0c000 ---p 0000d000 fd:00 393442                        
/lib64/libgcc_s-4.1.0-20060219.so.1
3cdde0c000-3cdde0d000 rw-p 0000c000 fd:00 393442                        
/lib64/libgcc_s-4.1.0-20060219.so.1
2b35a6ae2000-2b35a6ae3000 rw-p 2b35a6ae2000 00:00 0
2b35a6afb000-2b35a6afd000 rw-p 2b35a6afb000 00:00 0
7fffffcee000-7fffffd03000 rw-p 7fffffcee000 00:00 0                      [stack]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0                  [vdso]
/sbin/new-kernel-pkg: line 89:  7010 Abandon                 /sbin/grubby
--add-kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default
$makedefault --title "$title" ${mbkernel:+--add-multiboot="$mbkernel"}
${mbargs:+--mbargs="$mbargs"} --args="root=$rootdevice $kernargs"
--remove-kernel="TITLE=$title"
Comment 2 Nicolas Mailhot 2006-02-25 07:46:56 EST
Also, bug #183011 is probably the same thing
Comment 3 Dave Jones 2006-02-26 18:11:12 EST
*** Bug 183011 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2006-02-26 18:11:43 EST
*** Bug 183021 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2006-02-26 18:12:27 EST
*** Bug 183079 has been marked as a duplicate of this bug. ***
Comment 6 Michael Schwendt 2006-02-26 20:47:55 EST
Some better details in bug 183011 comment 2 though, e.g. a good
stacktrace.
Comment 7 John Ellson 2006-02-26 21:16:21 EST
Same problem in: kernel-2.6.15-1.1988_FC5.x86_64
Comment 8 Dave Jones 2006-02-26 23:43:07 EST
It's not a kernel problem (so it'll show up for every kernel you install until
mkinitrd gets fixed).
Comment 9 Peter Jones 2006-02-27 18:23:56 EST
*** Bug 183241 has been marked as a duplicate of this bug. ***
Comment 10 Frank Arnold 2006-02-28 04:30:09 EST
*** Bug 183312 has been marked as a duplicate of this bug. ***
Comment 11 Frank Arnold 2006-02-28 04:32:54 EST
*** Bug 183319 has been marked as a duplicate of this bug. ***
Comment 12 Alexander Shopov 2006-02-28 06:02:01 EST
OK, later on I will try to experiment with the rawhide package and give back
some results or confirmation of fixing.
Comment 13 Alexander Shopov 2006-02-28 06:14:15 EST
I've just donloaded  mkinitrd-5.0.29-1 fromn here and can confirm that the issue
has been resolved.
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/mkinitrd-5.0.29-1.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.