Bug 1830231 - Fedora 31 -> 32 dependency problems
Summary: Fedora 31 -> 32 dependency problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1830628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 08:41 UTC by Till Maas
Modified: 2020-07-21 07:39 UTC (History)
5 users (show)

Fixed In Version: fedora-obsolete-packages-32-48
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-07 03:10:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Till Maas 2020-05-01 08:41:32 UTC
I recall that problems with packages updates should be reported somewhere and I think it was related to this package. Here are problems that I see:

 Problem 1: conflicting requests
  - nothing provides module(platform:f31) needed by module gimp:2.10:3120191106095052:f636be4b-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(platform:f31) needed by module ripgrep:latest:3120190803131619:22d7e2a5-0.x86_64
Fehler: 
 Problem 1: package python2-beautifulsoup4-4.9.0-1.fc31.noarch requires python2-lxml, but none of the providers can be installed
  - python2-lxml-4.4.0-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-beautifulsoup4-4.9.0-1.fc31.noarch
 Problem 2: package python2-matplotlib-2.2.5-1.fc31.x86_64 requires python2-backports-functools_lru_cache, but none of the providers can be installed
  - package python2-matplotlib-2.2.5-1.fc31.x86_64 requires python2.7dist(backports.functools-lru-cache), but none of the providers can be installed
  - python2-backports-functools_lru_cache-1.5-6.fc31.noarch does not belong to a distupgrade repository
  - problem with installed package python2-matplotlib-2.2.5-1.fc31.x86_64
 Problem 3: package python2-matplotlib-2.2.5-1.fc31.x86_64 requires python2-cycler >= 0.10.0, but none of the providers can be installed
  - package python2-matplotlib-2.2.5-1.fc31.x86_64 requires python2.7dist(cycler) >= 0.10, but none of the providers can be installed
  - package python2-matplotlib-tk-2.2.5-1.fc31.x86_64 requires python2-matplotlib(x86-64) = 2.2.5-1.fc31, but none of the providers can be installed
  - python2-cycler-0.10.0-10.fc31.noarch does not belong to a distupgrade repository
  - problem with installed package python2-matplotlib-tk-2.2.5-1.fc31.x86_64

Not sure what/if this needs to be added to fedora-obsolete-packages.

Comment 1 Miro Hrončok 2020-05-01 22:22:53 UTC
$ repoquery --releasever=32 --repo={fedora,updates{,-testing}} --latest=1 --obsoletes fedora-obsolete-packages | egrep 'beautifulsoup4|matplotlib'
python2-beautifulsoup4 < 4.8.1-2
python2-matplotlib < 2.2.4-6
python2-matplotlib-test-data < 2.2.3-2
python2-matplotlib-tk < 2.2.4-6
python2-matplotlib-wx < 2.2.4-6

Those versions just need to be bumped in fedora-obsolete-packages.


The dependency problem on modules should go away, because all modules should be reset on upgrade. What is your upgrade method?

Comment 2 Fedora Update System 2020-05-01 22:47:45 UTC
FEDORA-2020-fd04d74051 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fd04d74051

Comment 3 Fedora Update System 2020-05-02 05:54:31 UTC
FEDORA-2020-fd04d74051 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-fd04d74051`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fd04d74051

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Till Maas 2020-05-02 09:59:07 UTC
(In reply to Miro Hrončok from comment #1)

> The dependency problem on modules should go away, because all modules should
> be reset on upgrade. What is your upgrade method?

After the upgrade, the modules seem to be gone and gimp/ripgrep seems to be ursine. 

I was follwoing https://docs.fedoraproject.org/en-US/quick-docs/dnf-system-upgrade/

and using this command:

dnf system-upgrade download --refresh --releasever=32

Not really sure what the expected behaviour for modules is. The upgrade guide, the release notes and the common bugs do not mention anything about this AFAICS.

Comment 5 Miro Hrončok 2020-05-02 21:34:31 UTC
> After the upgrade, the modules seem to be gone and gimp/ripgrep seems to be ursine. 

That is the expected behavior.

Comment 6 Terje Røsten 2020-05-03 12:07:57 UTC
*** Bug 1830628 has been marked as a duplicate of this bug. ***

Comment 7 Till Maas 2020-05-03 16:20:00 UTC
(In reply to Miro Hrončok from comment #5)
> > After the upgrade, the modules seem to be gone and gimp/ripgrep seems to be ursine. 
> 
> That is the expected behavior.

yes, this works for me. But it's not so great that dnf reports problems when everything seems to work.

Comment 8 Miro Hrončok 2020-05-03 22:12:52 UTC
I agree. My expectation was that users won't see those problems (don't problems like this usually end the transaction?). Could you please report that to dnf if you have a reproducer?

Comment 9 Fedora Update System 2020-05-06 13:41:15 UTC
FEDORA-2020-b151af48ef has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b151af48ef

Comment 10 Fedora Update System 2020-05-07 03:10:17 UTC
FEDORA-2020-b151af48ef has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 valtestad 2020-07-21 07:37:18 UTC
July 21st. The following looks like a show stopper for F31 to F32 upgrade:
Error: 
 Problem: package python2-beautifulsoup4-4.9.1-1.fc31.noarch requires python2-lxml, but none of the providers can be installed
  - python2-lxml-4.4.0-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package python2-beautifulsoup4-4.9.1-1.fc31.noarch
[xxxx ~]$ sudo dnf system-upgrade reboot
Error: system is not ready for upgrade

Any advise on how to solve this issue?

Thanks!

Comment 12 Elliott Sales de Andrade 2020-07-21 07:39:56 UTC
Wait for https://bodhi.fedoraproject.org/updates/FEDORA-2020-43c3b1377e to go stable, or enable updates-testing to get it and leave karma so it will go stable quicker.


Note You need to log in before you can comment on or make changes to this bug.