Bug 1830364 - Resource Graph is Built Using Legacy Router CA ConfigMap
Summary: Resource Graph is Built Using Legacy Router CA ConfigMap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1833125 1833128 1833130
TreeView+ depends on / blocked
 
Reported: 2020-05-01 18:18 UTC by Daneyon Hansen
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1833128 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 408 0 None closed Bug 1830364: Updates Resource Graph to use default-ingress-cert CM 2020-12-07 06:58:28 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:45 UTC

Description Daneyon Hansen 2020-05-01 18:18:52 UTC
Description of problem:
kube-controller-manager uses the legacy cm/router-ca -n openshift-config-managed to build its resource graph. However, the targetconfig controller uses the new cm/default-ingress-cert -n openshift-config-managed resource to build cm/serviceaccount-ca -n openshift-kube-controller-manager.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. N/A

Actual results:
N/A

Expected results:
N/A

Additional info:
[1] updated the targetconfig controller but did not update the resource graph.


[1] https://github.com/openshift/cluster-kube-controller-manager-operator/pull/402

Comment 3 zhou ying 2020-05-08 07:17:20 UTC
Compared payload: 4.5.0-0.nightly-2020-05-06-003431 with payload: 4.4.0-0.nightly-2020-05-08-004736, the issue has fixed:

oc exec po/kube-controller-manager-operator-xxx cluster-kube-controller-manager-operator resource-graph  |dot -Tpng >output4.png

Comment 4 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.