Bug 1833128 - Resource Graph is Built Using Legacy Router CA ConfigMap
Summary: Resource Graph is Built Using Legacy Router CA ConfigMap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-controller-manager
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1833125 (view as bug list)
Depends On: 1830364
Blocks: 1833125
TreeView+ depends on / blocked
 
Reported: 2020-05-07 20:31 UTC by Daneyon Hansen
Modified: 2020-06-23 00:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1830364
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Resource Graph (387.57 KB, image/png)
2020-06-15 05:46 UTC, zhou ying
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-controller-manager-operator pull 409 None closed [release-4.4] Bug 1833128: Updates Resource Graph to use default-ingress-cert CM 2020-06-16 03:15:33 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:39 UTC

Comment 1 Daneyon Hansen 2020-05-07 20:41:09 UTC
*** Bug 1833125 has been marked as a duplicate of this bug. ***

Comment 2 Maciej Szulik 2020-05-20 08:25:14 UTC
PRs in the queue.

Comment 6 zhou ying 2020-06-15 05:46:46 UTC
Created attachment 1697300 [details]
Resource Graph

Comment 7 zhou ying 2020-06-15 05:51:30 UTC
Maciej Szulik :

Confirmed with payload: 4.4.0-0.nightly-2020-06-14-142924, the issue still not fixed. please see the attachment.

Comment 8 Maciej Szulik 2020-06-15 14:46:11 UTC
Looks like the build did not catch the fix, moving again to modified.

Comment 12 zhou ying 2020-06-18 03:01:56 UTC
Confirmed with payload: 4.4.0-0.nightly-2020-06-17-090638, the issue has fixed:

oc exec po/kube-controller-manager-operator-xxx cluster-kube-controller-manager-operator resource-graph  |dot -Tpng >output4.png

Comment 14 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.