Bug 183058 - Keyboard switching with Shifts for Greek not working
Keyboard switching with Shifts for Greek not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 15:10 EST by Simos Xenitellis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 13:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simos Xenitellis 2006-02-25 15:10:18 EST
Description of problem:
When a users installs Fedora Core and selects Greek as the default keyboard
layout, Fedora creates default settings in xorg.conf to accomodate the choice.
However, the keyboard shortcut to switch between English and Greek, Both Shift
keys, does not work, therefore it is not possible to switch.

Version-Release number of selected component (if applicable):
1.0.1-4

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 5 (test3+) selecting the Greek keyboard layout.
2. Press Shift+Shift to switch between layouts (us and gr)

[==== Or set the xorg.conf section to
Section "InputDevice"
 	Driver      "kbd"
 	Option	    "XkbModel" "pc105"
 	Option	    "XkbLayout" "us,gr"
	Option	    "XkbOptions" "grp:shift_toggle,grp_led:scroll"
 EndSection
====]
  
Actual results:
The layout does not toggle.

Expected results:
The layout should toggle between English and Greek.

Additional info:

The following patch fixes the problem (changes the keyboard shortcut to
Alt-Shift, which is commonly used to switch between languages in Greek):

--- /etc/X11/xorg.conf.ORIGINAL	2006-02-25 18:45:13.000000000 +0000
+++ /etc/X11/xorg.conf	2006-02-25 18:47:59.000000000 +0000
@@ -57,7 +57,7 @@ Section "InputDevice"
 	Driver      "kbd"
 	Option	    "XkbModel" "pc105"
 	Option	    "XkbLayout" "us,gr"
-	Option	    "XkbOptions" "grp:shift_toggle,grp_led:scroll"
+	Option	    "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
 EndSection
 
 Section "InputDevice"


As far as I know, xorg.conf is generated from an application (which?), therefore
it is an issue of updating a master configuration file, replace "shift_toggle"
with "alt_shift_toggle".
Comment 1 Mike A. Harris 2006-02-25 15:54:08 EST
X configuration is not handled by the xkbdata package.

Reassigning to system-config-keyboard
Comment 2 Paul Nasrat 2006-02-28 10:41:16 EST
Please retry with a later tree, the keyboard_models in rhpl seems configured
correctly for this.
Comment 3 Simos Xenitellis 2006-03-01 18:45:29 EST
I just updated my FC5t3.

There is no change in xorg.conf from the settings above, it lists
[====
Section "InputDevice"
 	Driver      "kbd"
 	Option	    "XkbModel" "pc105"
 	Option	    "XkbLayout" "us,gr"
	Option	    "XkbOptions" "grp:shift_toggle,grp_led:scroll"
 EndSection
====]

I am still not able to switch between layouts by pressing both Shift keys.

My preference would be to get the default case to switch layouts by:
alt_shift_toggle (pressing Alt-Shift). To the best of my knowledge, most users
prefer this shortcut.

I now noticed that when I press the CapsLock key, the Scroll led toggles (it
lits the opposite way of the CapsLock led so either one is lit at a single
moment). However, this does not affect switching layouts.
Comment 4 Chris Lumens 2006-03-02 09:44:06 EST
No, you'll have to use s-c-keyboard or something to "change" your layout so it
can write out the correct xorg.conf file.  Or the easier fix for you would be to
change this line:

	Option	    "XkbOptions" "grp:shift_toggle,grp_led:scroll"

to:

	Option	    "XkbOptions" "grp:shifts_toggle,grp_led:scroll"

Note the very small change there.  That's why these kinds of bugs are so fun to
track down!  Of course, you could also change it to your preferred toggle
method, but the shifts_toggle is the one we'll be using in FC5.  Also note that
there was a bit of a shake up in how the keyboard model stuff is done in X, so
make sure that's all updated properly if you continue to have layout problems.
Comment 5 Simos Xenitellis 2006-03-02 10:53:20 EST
Thanks Chris!
This puts the issue in perspective.
Comment 6 Chris Lumens 2006-06-21 15:09:36 EDT
*** Bug 186629 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.