Bug 186629 - Cant write in English in Firstboot when Greek keyboard is selected as default
Cant write in English in Firstboot when Greek keyboard is selected as default
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
bzcl34nup
: Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-03-24 15:26 EST by Nikos Charonitakis
Modified: 2008-10-10 15:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 15:33:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.70 KB, application/octet-stream)
2006-03-28 17:09 EST, Nikos Charonitakis
no flags Details

  None (edit)
Description Nikos Charonitakis 2006-03-24 15:26:33 EST
Description of problem:
On a FC5 installation if a user selects Greek keyboard as the keyboard for the
system, then in firstboot he can only use Greek keyboard (no way to change it to
US) and this prevents him to create a normal account also gives him some source
for confusion :)


Version-Release number of selected component (if applicable):


How reproducible:
install fc5 selecting Greek keyboard as default keyboard for the system

Steps to Reproduce:
1. try to write some english text in a text box (create a user) 
2. try to change to US keyboard
3.
  
Actual results: cant create a normal user during firstboot


Expected results: write in English


Additional info:
Comment 1 Nikos Charonitakis 2006-03-24 15:29:07 EST
i forgot to mention in Expected results: write in English by default (as it
happens for xorg when Greek keyboard is selected)
Comment 2 Chris Lumens 2006-03-24 16:12:29 EST
What happens if you press both shift keys down at the same time before typing
into a text box?
Comment 3 Nikos Charonitakis 2006-03-24 21:34:08 EST
nothing happens. i have checked it before and i ll check it once more. But this
have not to be the default behaviour: during firstboot keyboard must be in US mode.
Comment 4 Nikos Charonitakis 2006-03-25 06:44:43 EST
nothing happens by pressing L+R Shift :confirmed for second time...
Comment 5 Chris Lumens 2006-03-28 14:33:47 EST
Please attach your /etc/X11/xorg.conf to this bug report.  I have done an
install with the Greek keyboard here and in firstboot, I have the US layout as
the default and pressing both shift keys switches to Greek.
Comment 6 Nikos Charonitakis 2006-03-28 17:09:29 EST
Created attachment 126942 [details]
xorg.conf
Comment 7 Chris Lumens 2006-06-21 15:09:22 EDT

*** This bug has been marked as a duplicate of 183058 ***
Comment 8 Nikos Charonitakis 2006-10-10 19:08:41 EDT
On a F6t3 installation if a user selects Greek keyboard as the keyboard for the
system, then in firstboot he can only use Greek keyboard (no way to change it to
US) and this prevents him to create a normal account also gives him some source
for confusion :)

switching between different keyboards (el/US) it is not possible again...

As you see the same firstboot FC5 problem is alive and kicking :)
Comment 9 Dimitris Glezos 2006-10-10 20:07:29 EDT
This is not a duplicate of Bug #183058.

The expected behaviour is the user to write be default in english and be able to
switch keyboard layout with Control-Shift.

I'm adding this as a Target for FC6 because it is very important for greek users.
Comment 10 Chris Lumens 2006-10-11 14:19:58 EDT
I just did an install with a Greek keyboard and English language.  When I get
into firstboot, the keyboard is set in English.  When I get to an entry box, I
am able to press both shifts simultaneously and it switches into the Greek
layout.  I am able to type in both and see characters from both.  Not sure why
you guys are still seeing problems with this.
Comment 11 Nikos Charonitakis 2006-10-27 09:52:10 EDT
Chris. i checked it again on a dell620 laptop with fc6 and i have problem again.
(Greek keyboard on firstboot,cant switch to US). Let us test it some more with
other installations and i will report again...
Comment 12 Nikos Charonitakis 2006-10-30 08:54:22 EST
I ve tested on my desktop system and everything is fine there.
This is a bit strange. Laptop's non standard keyboard may cause the problem.
I dont know...
Comment 13 Konstantin Dmitryev 2007-02-12 06:09:18 EST
This problem is also exist if you selecting a Russian Keyboard during
installation process.
I tell more: this problem exist surely for me in Fedora Core 3, 4 and 6.
Tested on different computers.

You must mark this bug as OPEN!
Comment 14 Dimitris Glezos 2007-02-12 07:59:06 EST
Shouldn't we at least mention on the screen what keyboard combination can the
user use to switch between keyboard layouts?
Comment 15 Nikos Charonitakis 2007-04-29 16:12:57 EDT
This problem appears again in f7t4.Create a user for the system is not possible
because keyboard writes only in Greek (should write in english by default) and
still there is no way to switch layout.
Comment 16 Chris Lumens 2007-04-30 12:56:20 EDT
This is only happening when firstboot is started from rhgb, so I'm reassigning
to that component.

From a brief look at the code, it looks like rhgb's keyboard code doesn't know
how to handle the more advanced layout line we're setting up, nor does it handle
passing the options to set xkbmap.  For your reference, the keyboard section on
a fresh install with a Greek keyboard layout looks like so:

Section "InputDevice"
    Identifier          "Keyboard0"
    Driver              "kbd"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "us,gr"
    Option "XkbOptions" "grp:shifts_toggle,grp_led:scroll"
EndSection
Comment 17 Bug Zapper 2008-04-03 13:10:43 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 18 Bug Zapper 2008-05-06 20:27:53 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 19 Nikos Charonitakis 2008-05-14 17:25:09 EDT
The return of this Bug:

On a F9 installation if a user selects Greek keyboard as the keyboard for the
system, then in firstboot he can only use Greek keyboard (no way to change it to
US) and this prevents him to create a normal account also gives him some source
for confusion :)

Mentioned by another user but also i saw it myself again.
Comment 20 Nikos Charonitakis 2008-08-03 17:40:32 EDT
still receiving negative comments from greek users about this. Please reopen.
Comment 21 Dimitris Glezos 2008-08-03 20:48:19 EDT
Reopening since the bug is still present.
Comment 22 Ray Strode [halfline] 2008-10-10 15:33:42 EDT
This won't be a problem in F10 since RHGB is out of the picture.

Note You need to log in before you can comment on or make changes to this bug.