Bug 1830609 - aqbanking crashes gnucash
Summary: aqbanking crashes gnucash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: aqbanking
Version: 32
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-03 00:37 UTC by Henrique Martins
Modified: 2020-05-13 18:21 UTC (History)
4 users (show)

Fixed In Version: aqbanking-6.1.4-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-12 03:07:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Henrique Martins 2020-05-03 00:37:56 UTC
Description of problem:
gnucash that comes with fc32 crashes downloading online transacions, because it upgraded to a broken version aqbanking.

Version-Release number of selected component (if applicable):
aqbanking-6.0.1-2.fc32.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run gnucash
2. try to use online actions, e.g. get transations, list of accounts

Actual results:
Crash

Expected results:
Working as it did for fc31

Additional info:
According to the gnucash folks this is due to bugs in the latest versions of aqbanking, see
   https://bugs.gnucash.org/show_bug.cgi?id=797713

Please repackage aqbanking-5.8.2-1.fc31.x86_64.rpm for Fc32

Downgrading to the fc31 versions force to install python 3.7, not sure I want to (do that, if a working aqbanking can be repackaged.)

Comment 1 Rex Dieter 2020-05-03 18:38:25 UTC
IMHO, let's give aqbanking at least a chance to address the issue before being drastic to revert things and lose features.

Fwiw, aqbanking was updated add support for new requirements from many banks (downgrading would cause loss of functionality for those users).

Comment 2 Henrique Martins 2020-05-03 19:11:14 UTC
Meanwhile I can't use gnucash's online functions, my fault for updating :-)
Aqbanking6's README file does say:
  PLEASE NOTE: AqBanking6 is work in progress, it is by no means stable or fit for use in production

Comment 3 Rex Dieter 2020-05-04 12:57:54 UTC
That's unfortunate.

In the meantime, I'll prepare builds of the latest releases for testing, aqbanking-6.1.4, gwenhywfar-5.3.0.tar.gz

Comment 4 Bill Nottingham 2020-05-05 14:16:47 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1743038#c9, I thought 6 was for rawhide, not F32.

Comment 5 Rex Dieter 2020-05-05 18:26:51 UTC
It was rawhide at the time, that was prior to f32 branching.

Here's a reference to an example bug about the newer features that required v6, bug #1763485

Comment 6 Rex Dieter 2020-05-05 18:34:40 UTC
Nothing jumps out at me on
https://aquamaniac.de/rdm/projects/aqbanking/issues?set_filter=1&tracker_id=1
about this being a known issue, but I'm not fluent in German either.

Comment 7 Henrique Martins 2020-05-05 18:38:15 UTC
Thus FC32/Aqbanking6 works for people in Europe (Germany?) that use some non-OFX connect type of access to their European bank and it's broken for people in the USA that mostly use OFX to access USA banks.

Comment 8 Rex Dieter 2020-05-05 20:48:21 UTC
More links,
https://lists.gnucash.org/pipermail/gnucash-user/2019-December/088350.html
"just a general note on AqBanbkings OFX DirectConnect plugin:

Development on this plugin is pretty much on hold right now..."


Sounds like there is no good choice here:
* stay indefinitely on an older aqbanking stack.  PROS: Working ofx
* Follow latest aqbanking development.  PROS: aqbanking upstream support, new features (like PSD2).  CONS: OFX feature development stalled, with regressions

I'll defer to Bill how he wants to handle reverting or not.  I'm OK with either option.

My tentative take:  regressions suck... a lot.  So, consider reverting things for F32 release, and rawhide?  Probably revert there too?  Tough call.


Corollary: create COPR with latest aqbanking builds (and dependencies, gnucash/kmymoney mostly), for stable fedora releases.  Users who want/need these new features then can opt-in to have them.



Thoughts, opinions?

Comment 9 Henrique Martins 2020-05-05 20:53:13 UTC
Picked up aqbanking-6.1.4-1.fc33.x86_64 and gwenhywfar-5.3.0-1.fc33.x86_64 from koji.
OFX works. Maybe the plugin is not on hold anymore?
Close the ticket when this is pushed to stable?

Comment 10 Rex Dieter 2020-05-05 20:54:05 UTC
Sigh, sorry for spam,

https://bugs.gnucash.org/show_bug.cgi?id=797713#c10

Looks like latest aqbanking/gwenhywfar does fix the issue at hand, that's excellent news.  I think that's the best way forward in the short term.  I'll prep f32 updates.

Comment 11 Henrique Martins 2020-05-05 21:01:15 UTC
Thanks Rex! (You did create those f33 rpms.)

Comment 12 Bill Nottingham 2020-05-05 21:42:21 UTC
Yeah, COPR would definitely be a last resort, as the ABI changes means you need to build *everything*.

I'm good with a roll-forward to latest if it works.

Comment 13 Fedora Update System 2020-05-06 03:20:19 UTC
FEDORA-2020-24e4addb7e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-24e4addb7e

Comment 14 Henrique Martins 2020-05-06 16:45:58 UTC
FC32 builds also works with my bank

Comment 15 Fedora Update System 2020-05-07 05:20:48 UTC
FEDORA-2020-24e4addb7e has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-24e4addb7e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-24e4addb7e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Bill Nottingham 2020-05-11 02:29:53 UTC
Had to re-do setup, but this did work for me as well.

Comment 17 Fedora Update System 2020-05-12 03:07:55 UTC
FEDORA-2020-24e4addb7e has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 John Haiducek 2020-05-13 18:08:48 UTC
Still getting an error after updating to aqbanking-6.1.4-1.fc32. GnuCash doesn't crash for me, but it issues the error: "error on executing job. status: enqueued (1)"

Comment 19 Henrique Martins 2020-05-13 18:18:17 UTC
Try the following.
- exit gnucash
- remove (or rename or move, just in case) the ~/.aqbanking/settings6 directory
- try again

Comment 20 John Haiducek 2020-05-13 18:21:11 UTC
(In reply to Henrique Martins from comment #19)
> Try the following.
> - exit gnucash
> - remove (or rename or move, just in case) the ~/.aqbanking/settings6
> directory
> - try again

Thanks Henrique. I got it working by a different method:

- Opened Online Banking Setup in Gnucash
- Click Next, open the Aqbanking setup wizard
- Select "Edit User"
- Go to the "Bank Settings" tab
- Clicked "Retrieve Account List"


Note You need to log in before you can comment on or make changes to this bug.