Bug 183079 - Kernel not installing properly
Kernel not installing properly
Status: CLOSED DUPLICATE of bug 183010
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 20:23 EST by ryuhei yokokawa
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 18:12:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ryuhei yokokawa 2006-02-25 20:23:11 EST
Description of problem:
When installing the 2.6.15-1.1977 kernel it spits out problems and does not
install properly.
Also, the 1977 kernel leaves my machine with a kernel panic when I boot the
kernel by manually editting grub.conf

Version-Release number of selected component (if applicable):


How reproducible:
Very (install, reinstall and yet the problem persists)


Steps to Reproduce:
1.Install FC5_T3
2.yum update everything
3.The kernel does not get installed properly
4.Tried reinstalling kernel
5.Still not working
  
Actual results:
Look at the result on the "Additional Info" section

Expected results:
Just a normal kernel install without problems.
Be able to reboot and into the new kernel without a kernel panic.


Additional info:
Just installed FC5_T3 and yum updated.  Nothing has yet to be altered.

This is what rpm spits out:
[root@localhost xys]# rpm -e kernel-devel-2.6.15-1.1977_FC5 kernel-2.6.15-1.1977_FC5
*** glibc detected *** /sbin/grubby: double free or corruption (out): 0xbfd77b60 ***
======= Backtrace: =========
/lib/libc.so.6[0xe23de8]
/lib/libc.so.6(__libc_free+0x79)[0xe272ed]
/sbin/grubby[0x804fd12]
/sbin/grubby[0x804feb1]
/sbin/grubby[0x8050026]
/sbin/grubby[0x8050d02]
/lib/libc.so.6(__libc_start_main+0xdc)[0xdd57a4]
/sbin/grubby[0x804a001]
======= Memory map: ========
00111000-0011c000 r-xp 00000000 03:03 9493597    /lib/libgcc_s-4.1.0-20060219.so.1
0011c000-0011d000 rwxp 0000a000 03:03 9493597    /lib/libgcc_s-4.1.0-20060219.so.1
003cd000-003ce000 r-xp 003cd000 00:00 0          [vdso]
0044f000-00468000 r-xp 00000000 03:03 9493457    /lib/ld-2.3.90.so
00468000-00469000 r-xp 00018000 03:03 9493457    /lib/ld-2.3.90.so
00469000-0046a000 rwxp 00019000 03:03 9493457    /lib/ld-2.3.90.so
00dc0000-00ee3000 r-xp 00000000 03:03 9493464    /lib/libc-2.3.90.so
00ee3000-00ee6000 r-xp 00122000 03:03 9493464    /lib/libc-2.3.90.so
00ee6000-00ee7000 rwxp 00125000 03:03 9493464    /lib/libc-2.3.90.so
00ee7000-00eea000 rwxp 00ee7000 00:00 0
08048000-08089000 r-xp 00000000 03:03 12145260   /sbin/grubby
08089000-0808c000 rw-p 00041000 03:03 12145260   /sbin/grubby
0808c000-08094000 rw-p 0808c000 00:00 0
091b2000-091d3000 rw-p 091b2000 00:00 0          [heap]
b7e00000-b7e21000 rw-p b7e00000 00:00 0
b7e21000-b7f00000 ---p b7e21000 00:00 0
b7f61000-b7f62000 rw-p b7f61000 00:00 0
b7f7a000-b7f7b000 rw-p b7f7a000 00:00 0
bfd65000-bfd7b000 rw-p bfd65000 00:00 0          [stack]
/sbin/new-kernel-pkg: line 175:  2670 Aborted                 /sbin/grubby
--remove-kernel=$bootPrefix/$kernelName-$version
Comment 1 Paul Stauffer 2006-02-26 00:05:30 EST
I got the same errors during installation of the kernel package, but manually
adding the grub.conf entry allowed the kernel to boot normally.  Can you attach
your grub.conf?
Comment 2 ryuhei yokokawa 2006-02-26 01:36:07 EST
Here's my grub:

#boot=/dev/hda
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.15 with the 1977 something)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.1977_FC5 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.15-1.1977_FC5.img

title Fedora Core (2.6.15-1.1955_FC5)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.1955_FC5 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.15-1.1955_FC5.img

when you installed, did it spit out the exact same errors?
Comment 3 Dave Jones 2006-02-26 18:12:08 EST

*** This bug has been marked as a duplicate of 183010 ***

Note You need to log in before you can comment on or make changes to this bug.