Bug 183108 - Outdated font paths
Outdated font paths
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: t1lib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
: Reopened
: 246774 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-02-26 07:15 EST by Ville Skyttä
Modified: 2008-01-27 02:29 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.1.1-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 02:21:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-02-26 07:15:10 EST
Installing t1lib in devel barfs:

Output from t1lib-5.1.0-5.fc5@x86_64:
find: /usr/X11R6/lib/X11: No such file or directory

The font path used by t1libconfig appears outdated, it should be
/usr/share/X11/fonts for FC5.
Comment 1 Roozbeh Pournader 2006-02-26 08:16:44 EST
Thanks for the report. I just updated the path and requested a build.

As I don't have a rawhide box currently, I would really appreciate it if you
could test the new package and verify the fix.
Comment 2 Ville Skyttä 2006-02-27 02:23:26 EST
The error is gone, but while checking things out, I noticed a number of other
problems:

The path to the ghostscript fonts is wrong, should be
/usr/share/fonts/default/ghostscript on FC5.  Other paths you may want to add to
$fontdirs in t1libconfig are /usr/share/fonts/default/Type1,
/usr/share/libwmf/fonts and /usr/share/a2ps/fonts.

Then, a find command in t1libconfig barfs:
Searching for Type 1 fonts and AFM files...find: warning: you have specified the
-maxdepth option after a non-option argument -name, but options are not
positional (-maxdepth affects tests specified before it as well as those
specified after it).  Please specify options before other arguments.

Third, the package ships man page for xglyph, but no such program exists in it.

Fourth, the package refreshes its font database only in %post, which means stuff
installed after it won't become automatically available.  Using triggers would
improve it, for example (assuming the above new paths are added to fontpath, and
untested):

   %triggerin -- ghostscript-fonts, urw-fonts, libwmf, a2ps
   %{_sbindir}/t1libconfig --force > /dev/null || :

   %triggerpostun -- ghostscript-fonts, urw-fonts, libwmf, a2ps
   %{_sbindir}/t1libconfig --force > /dev/null || :

The "|| :" would not hurt in the %post script's t1libconfig line either.
Comment 3 Ville Skyttä 2006-03-24 18:05:12 EST
ping
Comment 4 Roozbeh Pournader 2006-11-09 12:08:53 EST
I'm so sorry, not having the time for maintaining t1lib, I just orphaned the
package. Feel free to fix/take care yourself.
Comment 5 José Matos 2006-11-15 04:55:36 EST
I will take care of this bug, since I will take care of the package.
Comment 6 Red Hat Bugzilla 2007-02-05 13:56:07 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 7 R P Herrold 2007-05-10 13:32:43 EDT
Confirmed today as still broken at 5.1.0-9

still leaking stderr noise

[herrold@centos-4 swftools]$ file /usr/sbin/t1libconfig
/usr/sbin/t1libconfig: Bourne shell script text executable
[herrold@centos-4 swftools]$     

Isn't it better to _Fix_ the darn script with a patch inside, -- and NOT paper
over it with a || :   or a > /dev/null specfile fix ?? 


$ sudo rpm -Uvh /home/herrold/rpmbuild/RPMS/i386/t1lib-devel-5.1.0-9.i386.rpm
/home/herrold/rpmbuild/RPMS/i386/t1lib-5.1.0-9.i386.rpm
Password:
Preparing...                ########################################### [100%]
   1:t1lib                  ########################################### [ 50%]
find: /usr/share/X11/fonts: No such file or directory
   2:t1lib-devel            ########################################### [100%]
$
Comment 8 José Matos 2007-08-29 19:21:19 EDT
*** Bug 246774 has been marked as a duplicate of this bug. ***
Comment 9 Patrice Dumas 2008-01-05 19:20:49 EST
This is half fixed in rawhide. Not completely since the newly
installed fonts won't be added in the files. However the
generated files are (unless I am wrong) only used by xglyph 
currently. So fixing this is not high priority and would imply adding 
post scripts to packages that install type1 fonts (triggers are
not the right solution) and therefore going through
the packaging commitee.

I sent a mail to the debian maintainer to come with a better
solution if he is interested in fixing this issue, but once
again I don't think that it is that important.

For this reason, I don't think it deserves to be pushed to
older branches. Somebody can do it, though, either José if he 
cares, or anybody else since there are no ACLs.
Comment 10 Patrice Dumas 2008-01-08 17:36:09 EST
Pushing to older branches for the xglyph issue.
Comment 11 Fedora Update System 2008-01-11 17:14:39 EST
t1lib-5.1.1-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update t1lib'
Comment 12 Fedora Update System 2008-01-11 17:27:23 EST
t1lib-5.1.1-7.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update t1lib'
Comment 13 Fedora Update System 2008-01-27 02:21:39 EST
t1lib-5.1.1-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-01-27 02:29:25 EST
t1lib-5.1.1-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.