Bug 183132 - Firstboot always running at boot.
Firstboot always running at boot.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
: 197551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 14:23 EST by Philip Wyett
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 12:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Wyett 2006-02-26 14:23:46 EST
Description of problem:

After installing FC5 Test 3 and successfully performing firstboot config. First
boot is not disabled and runs at every boot though the config part of it is
never seen.

Version-Release number of selected component (if applicable):

1.4.4-1

How reproducible:

Steps to Reproduce:
1. Install FC5 Test 3 in vmware or x86 boxen.
2. Reboot and perform firstboot config.
3. Reboot as many times as you like and watch firstboot being
   executed during boot and visible through rhgb.

Additional info:

A check into system-config-services shows firstboot is still checked to run and
not disabled.
Comment 1 Chris Lumens 2006-02-27 12:38:52 EST
The service itself isn't actually running.  What's happening here is that the
init script for it is checking for a lock file to determine whether it should
run or not.  This is to prevent the pretty weird corner case of if firstboot
fails to start in runlevel 5 for some reason (for instance, X is all screwed up)
but then you switch into runlevel 3 to fix it.  Without some extra protection,
firstboot will attempt to start again on the terminal.  See bug 145169.
Comment 2 Chris Lumens 2006-07-05 11:19:26 EDT
*** Bug 197551 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.