Bug 1831533 - stop printing usage help when the server commands
Summary: stop printing usage help when the server commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Lukasz Szaszkiewicz
QA Contact: Ke Wang
URL:
Whiteboard:
: 1822417 (view as bug list)
Depends On:
Blocks: 1838195 1838197 1838198 1838199
TreeView+ depends on / blocked
 
Reported: 2020-05-05 07:29 UTC by Lukasz Szaszkiewicz
Modified: 2020-07-13 17:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1838195 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24945 0 None closed Bug 1831533: stop printing usage help when the server commands exit 2021-02-19 01:56:17 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:11 UTC

Description Lukasz Szaszkiewicz 2020-05-05 07:29:39 UTC
move https://github.com/kubernetes/kubernetes/pull/90297 into origin so that help is not printed when kube-apiserver fails with a non usage based error

Comment 3 Ke Wang 2020-05-07 07:45:51 UTC
Verified with OCP build 4.5.0-0.nightly-2020-05-06-003431,

- On 4.4 OCP without fix ENV, get the related errors
...
2020-05-06T15:10:17.009079506+00:00 stderr F Usage:
2020-05-06T15:10:17.009079506+00:00 stderr F   kube-apiserver [flags]
2020-05-06T15:10:17.009079506+00:00 stderr F
2020-05-06T15:10:17.009079506+00:00 stderr F Generic flags:
2020-05-06T15:10:17.009079506+00:00 stderr F
...

- In one terminal, enter into master 
$ master=$(oc get nodes | grep master | head -1 | cut -d " " -f1)
$ oc debug node/$master
sh-4.2# chroot /host
Try incorrect parameter to endpoint,
sh-4.4#  curl -k --silent --show-error https://localhost:6443/readyz1

$ cd /var/log/pods

$ grep -nr -i 'usage' openshift-*

No results found.

So the bug was fixed, move the bug verified.

Comment 4 David Eads 2020-05-20 14:54:04 UTC
*** Bug 1822417 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-07-13 17:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.