Bug 1838199 - stop printing usage help when the server commands
Summary: stop printing usage help when the server commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Lukasz Szaszkiewicz
QA Contact: Ke Wang
URL:
Whiteboard:
: 1838195 (view as bug list)
Depends On: 1831533
Blocks: 1838196
TreeView+ depends on / blocked
 
Reported: 2020-05-20 15:59 UTC by OpenShift BugZilla Robot
Modified: 2020-06-25 03:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-02 11:18:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25005 None closed Bug 1838199: stop printing usage help when the server commands exit 2020-07-27 18:53:06 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:56 UTC

Comment 4 Ke Wang 2020-05-26 10:09:47 UTC
Verified with OCP build 4.4.0-0.nightly-2020-05-25-115719,

- On 4.4 OCP without fix ENV, get the related errors
...
2020-05-06T15:10:17.009079506+00:00 stderr F Usage:
2020-05-06T15:10:17.009079506+00:00 stderr F   kube-apiserver [flags]
2020-05-06T15:10:17.009079506+00:00 stderr F
2020-05-06T15:10:17.009079506+00:00 stderr F Generic flags:
2020-05-06T15:10:17.009079506+00:00 stderr F
...

- In one terminal, enter into master 
$ master=$(oc get nodes | grep master | head -1 | cut -d " " -f1)
$ oc debug node/$master
sh-4.2# chroot /host
Try incorrect parameter to endpoint,
sh-4.4#  curl -k --silent --show-error https://localhost:6443/readyz1

$ cd /var/log/pods

$ grep -nr -i 'usage' openshift-*

No results found.

So the bug was fixed, move the bug verified.

Comment 6 errata-xmlrpc 2020-06-02 11:18:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310

Comment 7 David Eads 2020-06-18 13:45:33 UTC
*** Bug 1838195 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.