Bug 1831808 - Operand's list view - "Status" column doesn't display the latest 'status.conditions''
Summary: Operand's list view - "Status" column doesn't display the latest 'status.cond...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1831810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 16:48 UTC by tony.wu
Modified: 2020-06-23 00:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The console code is not checking condition.status before using a condition as the operand status. And it also is not making sure phase, status, or state are strings before displaying them. Consequence: The "Status" column on the operand list view doesn't display the latest status seen on the details and YAML view. Fix: Update the console code so it checks condition.status before using a condition as the operand status. And also make sure phase, status, or state are strings before displaying them. Result: The "Status" column on the operand list view displays the latest status seen on the details and YAML view.
Clone Of:
: 1831810 (view as bug list)
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
1_appsody-operator__AppsodyApplication-list-view (289.84 KB, image/png)
2020-05-05 16:48 UTC, tony.wu
no flags Details
2_appsody-operator__AppsodyApplication-details-view.png (446.86 KB, image/png)
2020-05-05 16:48 UTC, tony.wu
no flags Details
3_appsody-operator__AppsodyApplication-YAML-view.png (436.92 KB, image/png)
2020-05-05 16:48 UTC, tony.wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5616 None closed [release-4.4] Bug 1831808: fix bug where operand list status does not show latest … 2020-06-19 18:13:55 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:42 UTC

Description tony.wu 2020-05-05 16:48:11 UTC
Created attachment 1685300 [details]
1_appsody-operator__AppsodyApplication-list-view

Description of problem:
If Operand's 'status.conditions' has an array of status, the "Status" column on Operand's list view doesn't display the latest status.

Version-Release number of selected component (if applicable):
OCP 4.4 and 4.5

How reproducible:
100%

Steps to Reproduce:
1. Go to "OperatorHub", install "Appsody" Operator (or "Cockroachdb" Operator)
2. Go to "Installed Operators" view, create "AppsodyApplication" instance (or "cockroachdb" instance)
3. Go to Operand's list view, details view, and YAML view to compare Status

Actual results:
"Status" column on the list view doesn't display the latest status seen on the details and YAML view.

Expected results:
"Status" column on the list view displays the latest status seen on the details and YAML view.


Additional info:

Comment 1 tony.wu 2020-05-05 16:48:41 UTC
Created attachment 1685301 [details]
2_appsody-operator__AppsodyApplication-details-view.png

Comment 2 tony.wu 2020-05-05 16:48:58 UTC
Created attachment 1685302 [details]
3_appsody-operator__AppsodyApplication-YAML-view.png

Comment 3 Robb Hamilton 2020-05-07 14:10:20 UTC
https://github.com/openshift/console/pull/5238 needs to merge to release-4.4 before this can be back ported.

Comment 4 Robb Hamilton 2020-05-07 15:37:21 UTC
Move to upcoming sprint as dependent changes haven't merged yet.

Comment 5 Robb Hamilton 2020-05-28 19:59:08 UTC
PR opened, awaiting cherry pick approval.

Comment 8 Yanping Zhang 2020-06-11 13:49:02 UTC
Checked on ocp 4.4 cluster with payload 4.4.0-0.nightly-2020-06-11-064343
1. Install "Appsody" Operator, create "AppsodyApplication" instance.
2. Go to Operand's list view, details view, and YAML view to compare Status.
In the "Status" column, it shows "Conditions: DependenciesSatisfied, Reconciled", which are listed on details view and yaml.

Comment 10 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.