Bug 1831810 - Operand's list view - "Status" column doesn't display the latest 'status.conditions''
Summary: Operand's list view - "Status" column doesn't display the latest 'status.cond...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1831808
TreeView+ depends on / blocked
 
Reported: 2020-05-05 16:49 UTC by tony.wu
Modified: 2020-07-13 17:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1831808
Environment:
Last Closed: 2020-07-13 17:35:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
1_appsody-operator__AppsodyApplication-list-view.png (289.84 KB, image/png)
2020-05-05 16:49 UTC, tony.wu
no flags Details
2_appsody-operator__AppsodyApplication-details-view.png (446.86 KB, image/png)
2020-05-05 16:50 UTC, tony.wu
no flags Details
3_appsody-operator__AppsodyApplication-YAML-view.png (436.92 KB, image/png)
2020-05-05 16:50 UTC, tony.wu
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5315 0 None closed Bug 1831810: fix bug where operand list status does not show latest … 2020-06-24 01:43:42 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:32 UTC

Description tony.wu 2020-05-05 16:49:57 UTC
Created attachment 1685303 [details]
1_appsody-operator__AppsodyApplication-list-view.png

+++ This bug was initially created as a clone of Bug #1831808 +++

Description of problem:
If Operand's 'status.conditions' has an array of status, the "Status" column on Operand's list view doesn't display the latest status.

Version-Release number of selected component (if applicable):
OCP 4.4 and 4.5

How reproducible:
100%

Steps to Reproduce:
1. Go to "OperatorHub", install "Appsody" Operator (or "Cockroachdb" Operator)
2. Go to "Installed Operators" view, create "AppsodyApplication" instance (or "cockroachdb" instance)
3. Go to Operand's list view, details view, and YAML view to compare Status

Actual results:
"Status" column on the list view doesn't display the latest status seen on the details and YAML view.

Expected results:
"Status" column on the list view displays the latest status seen on the details and YAML view.


Additional info:

--- Additional comment from  on 2020-05-05 16:48:41 UTC ---



--- Additional comment from  on 2020-05-05 16:48:58 UTC ---

Comment 1 tony.wu 2020-05-05 16:50:15 UTC
Created attachment 1685304 [details]
2_appsody-operator__AppsodyApplication-details-view.png

Comment 2 tony.wu 2020-05-05 16:50:27 UTC
Created attachment 1685305 [details]
3_appsody-operator__AppsodyApplication-YAML-view.png

Comment 5 shahan 2020-05-09 03:55:09 UTC
The operand list page will show ”Conditions: Initialized, Deployed“ status which same as yaml file
4.5.0-0.nightly-2020-05-08-200452

Comment 6 errata-xmlrpc 2020-07-13 17:35:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.