Bug 183205 - aspell no longer accepts 'strip-accents: false' configuration.
aspell no longer accepts 'strip-accents: false' configuration.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
: 183204 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 08:32 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 09:32:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-02-27 08:32:55 EST
Since upgrading to rawhide, I can't convince aspell to work properly rather than
in dumbed-down 'strip-accents' mode. It doesn't like the option in
/etc/aspell.conf which used to make it work correctly:

hades /home/dwmw2 $ aspell -a
Error: /etc/aspell.conf:1: The key "strip-accents" is unknown.
Comment 1 David Woodhouse 2006-02-27 09:54:03 EST
When I say 'correctly', I mean I expect it to accept correct spellings of words
with accents. And I expect it to _correct_ me if I accidentally miss an accent.

This shows it misbehaving. It says 'no, yes, no' and gets it wrong in all three
cases:

@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.3)
rôle
& rôle 35 0: role, Roley, rile, Rolfe, roles, tole, roe, Ole, ole, roll, rule,
prole, Rolf, roue, Cole, Dole, Pole, Rome, Rose, Rowe, Roze, bole, dole, hole,
mole, pole, robe, rode, rope, rose, rote, rove, sole, vole, role's

role
*

café
& café 21 0: cafe, cafes, Cage, cage, chafe, caff, cave, CARE, Cale, Care, Case,
Cate, Caye, Rafe, cake, came, cane, cape, care, case, safe
Comment 2 Ivana Varekova 2006-03-02 09:32:50 EST
The strip-accents option is not supported in the last version of aspell (see
/usr/share/doc/aspell-0.60.3/README). From the version 0.60 there have been
separated world lists with and without accents (aspell uses world lists without
accents implicitly). 
The spell checking for text with accents should be done by set 
master option to "world_list_with_accents" now. 
There was a misstake in aspell man page - option strip-accents was mentioned
there. It is fixed from aspell-0.60.3-4.
Comment 3 David Woodhouse 2006-03-02 10:13:49 EST
Thanks, I'll try that.

Actually, I believe that the with-accents dictionary ought to be the _default_
now that we handle UTF-8 everywhere. The old excuse that keyboards and
typewriters can't handle accents is no longer valid.

Admittedly, there are people who _deliberately_ want to stick to ASCII, but in
general those are the people who can't be bothered to pay any attention to the
results of aspell anyway.

If people are actually bothering to run a spell-checker, or to pay any attention
to the results which an automatic spell-checker offers, then it's reasonable to
assume that they do actually care about being correct. They're probably omitting
the accents just because they don't know how to enter them, and a
spell-checker's auto-replace functionality could be very useful to them.
Comment 4 Matěj Cepl 2007-11-05 10:24:02 EST
*** Bug 183204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.