Bug 183212 - Source links in console from stack traces don't work
Source links in console from stack traces don't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
: 188264 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 10:04 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.1.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 02:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (1.00 KB, application/octet-stream)
2006-03-06 09:52 EST, Anthony Green
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 146305 None None None Never
GNU Compiler Collection 27081 None None None Never

  None (edit)
Description Anthony Green 2006-02-27 10:04:25 EST
Description of problem:
If you run a java program within Eclipse that throws an uncaught exception, 
you see  a nice stack trace in the Console window.  The source:lineno links 
in the stack trace are clickable.  When I click a link to go to a line of source
in the program I'm running (my project), I expect it to take me there, but I get
an error instead.
For instance, my stack trace includes a line referring to Driver.java:41.  
When I click on that I get an "Information" dialog box, saying "Source not 
found for Driver".  It should actually take me to
org/spindazzle/sdc/driver/Driver.java, line 41, which 
is part of my project.  Is this because we're not printing additional path 
information in the exceptions?

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.2-1jpp_7fc

How reproducible:
Always

Steps to Reproduce:
1.Run a java program that prints an exception.  
2.Try to follow the source links in the exception trace.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Overholt 2006-02-27 13:30:16 EST
I think this is due to the way the program is being run.  Eclipse uses
"source-attached jars" for the source of certain bits of programs.  Perhaps this
is happening here?  CCing Ben as he knows about this.
Comment 2 Ben Konrath 2006-03-03 11:12:59 EST
I think Anthony is talking about stack traces in the eclipse console, not source
attached jars. This seems to be a regression, although last time it seems to
have fixed itself.
Comment 3 Anthony Green 2006-03-05 11:54:45 EST
(In reply to comment #2)
> I think Anthony is talking about stack traces in the eclipse console, not source
> attached jars. 

Yes, that's what I'm talking about. 

> This seems to be a regression, although last time it seems to
> have fixed itself.

It's still broken for me.

Comment 4 Ben Konrath 2006-03-05 19:28:46 EST
This test file works for me:

public class Test {
	public static void main(String[] args) {
		new Exception().printStackTrace();
	}
}

I'm using rawhide with: 

eclipse-platform-3.1.2-1jpp_7fc
gcc-java-4.1.0-1

Can you post an example class that has a problem?


Comment 5 Anthony Green 2006-03-06 09:52:49 EST
Created attachment 125707 [details]
Reproducer
Comment 6 Anthony Green 2006-03-06 09:53:39 EST
It looks like source references in the default package are OK, but try something
in a sub-package.  See attached reproducer.
Comment 7 Ben Konrath 2006-04-08 01:54:04 EDT
This seems to be a classpath bug. Tracking upstream.
Comment 8 Mladen Adamovic 2006-04-08 02:14:30 EDT
*** Bug 188264 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Jelinek 2006-04-11 02:38:11 EDT
PR27081 fix added to gcc-4.1.0-7 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.